View Issue Details

IDProjectCategoryView StatusLast Update
0001337XdebugUsage problems (Wrong Results)public2016-11-16 18:37
ReporterisvizievAssigned Toderick 
PriorityurgentSeverityblockReproducibilityalways
Status resolvedResolutionnot fixable 
Product Version2.4.1 
Target VersionFixed in Version 
Summary0001337: Dockerized Xdebug breaks on access to class static property
DescriptionThis is reply for issue https://bugs.xdebug.org/view.php?id=1185.

This issue still reproducing on php 5.6, xdebug 2.4.1.

I can't reply in that issue, so I created new one. Feel free to convert my message as a reply to that issue.

I prepared git repo with instruction how to reproduce this issue.
https://github.com/ihor-sviziev/xdebug-issue-1185


Steps to reproduce, actual result, expected result see at README file in git repo.

I hope this issue will be fixed
TagsNo tags attached.
Operating System
PHP Version5.6.15-5.6.19

Relationships

duplicate of 0001185 resolvedderick Dockerized Xdebug breaks on access to class static property 

Activities

isviziev

2016-08-13 06:31

reporter   ~0003676

One more thing - this issue reproducing only in php 5.5.* and php 5.6.*. In php 7.0.* it isn't reproducing for me.

PS: if you want to "SSH" into running container you can use
docker exec -it xdebug-test bash

derick

2016-11-16 18:37

administrator   ~0003750

Hi!

I am closing this report, as it's not a bug in Xdebug and it doesn't seem to be that the bug is in PHP either, but rather in the compiler that Debian Jessie uses by default.

So the current conclusion is: compiler bug (or weird interaction between compiler and PHP).

I filed a bug for PHP at https://bugs.php.net/bug.php?id=73545, and I have emailed internals and cc-ed some PHP devs, but they don't seem interested :-(.

You can work around it by changing the -O2 to -O0 in the Makefile file after running "./configure" but before "make". Before you
run "./configure", don't forget to run "make clean" first.

Issue History

Date Modified Username Field Change
2016-08-13 06:22 isviziev New Issue
2016-08-13 06:31 isviziev Note Added: 0003676
2016-11-16 18:37 derick Note Added: 0003750
2016-11-16 18:37 derick Relationship added duplicate of 0001185
2016-11-16 18:37 derick Status new => resolved
2016-11-16 18:37 derick Resolution open => not fixable
2016-11-16 18:37 derick Assigned To => derick