View Issue Details

IDProjectCategoryView StatusLast Update
0001345XdebugRemote Debuggingpublic2016-12-12 00:12
ReporterPeterBrandZA56Assigned Toderick 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformPHP Version 5.6.14OSWindowsOS Version10 anniv
Product Version2.4.1 
Target VersionFixed in Version 
Summary0001345: Extension is disabled in IIS and gives server error if enabled
DescriptionI had remote debugging working, but it does not work in the last week - possibly due to a Windows update?

Running IIS 1607 (OS build 14393.82), PHP Manager tells me the extension has been disabled and if I enable it, all php page report a server error. Disabling it again lets PHP pages work again, no restart or reboot required. PHP info shows that the xdebug settings I have in my php.ini file have not been applied (xdebug.remote_enable is off for example). Nothing in php_error.log or application error log that I can see.

Checked with wizard that I am running the correct version.
TagsNo tags attached.
Operating SystemWindows 10
PHP Version5.6.10-5.6.14

Activities

derick

2016-12-04 16:27

administrator   ~0003913

Is still still causing an issue for you? I have no problems loading and using the extension with Windows (8).

PeterBrandZA56

2016-12-05 21:37

reporter   ~0003948

Yes still an issue in windows 10 anniversary.

PHP.ini has

[xdebug]
zend_extension="C:\Program Files (x86)\PHP\ext\php_xdebug-2.3.3-5.6-vc11-nts.dll"
xdebug.idekey=xdebug
xdebug.remote_enable=1
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_host=127.0.0.1
xdebug.remote_port=9000
xdebug.remote_log="C:\Temp\Xdebug\xdebug.log"
xdebug.show_exception_trace=0
xdebug.show_local_vars=9
xdebug.show_mem_delta=0
xdebug.trace_format=0
xdebug.scream=0
xdebug.profiler_output_dir ="c:\Temp\Xdebug"
xdebug.profiler_output_name = "callgrind.%s.out"
xdebug.profiler_enable = 0
xdebug.profiler_enable_trigger = 1

but IIS lists the zend extension as Disabled, and phpinfo.php shows the settings have not been applied. PHP errors are nevertheless displayed in html in an Xdebug table, and debug handler DBGP is functioning, but on one local site only.

derick

2016-12-06 19:19

administrator   ~0003952

You are using an old version of Xdebug (2.3.3) - can you please upgrade to Xdebug 2.5.0 and try to see whether it works there?

PeterBrandZA56

2016-12-07 07:33

reporter   ~0003961

Upgraded to Xdebug 2.5.0 still the same symptoms.
Strange thing is PHP error messages are formatted by Xdebug, on all sites on localhost, but only one of them can be debugged with notepad++ and its DBGp plugin. It's as if PHP recognizes Xdebug, but IIS does not?

derick

2016-12-12 00:12

administrator   ~0004026

This sounds like a configuration issue. Please reach out through the support channels (as are described on https://xdebug.org/support.php) to figure out what's going wrong.

I'm closing this issue as I don't think there is an actual bug.

Issue History

Date Modified Username Field Change
2016-09-05 16:11 PeterBrandZA56 New Issue
2016-12-04 16:27 derick Note Added: 0003913
2016-12-04 16:27 derick Assigned To => derick
2016-12-04 16:27 derick Status new => feedback
2016-12-05 21:37 PeterBrandZA56 Note Added: 0003948
2016-12-05 21:37 PeterBrandZA56 Status feedback => assigned
2016-12-06 19:19 derick Note Added: 0003952
2016-12-06 19:19 derick Status assigned => feedback
2016-12-07 07:33 PeterBrandZA56 Note Added: 0003961
2016-12-07 07:33 PeterBrandZA56 Status feedback => assigned
2016-12-12 00:12 derick Note Added: 0004026
2016-12-12 00:12 derick Status assigned => resolved
2016-12-12 00:12 derick Resolution open => unable to reproduce