View Issue Details

IDProjectCategoryView StatusLast Update
0001350XdebugUsage problems (Wrong Results)public2016-10-04 19:21
ReportermcordingleyAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformLinuxOSDebianOS VersionTesting
Product Version2.4.1 
Target VersionFixed in Version 
Summary0001350: Segmentation Fault on Code Coverage
DescriptionOne of my tests is causing XDebug to segfault. Running it through GDB gives some information:

```
vagrant@StretchBox /vagrant (master*) $ gdb --args php vendor/bin/phpunit --coverage-html public/coverage
GNU gdb (Debian 7.11.1-2) 7.11.1
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from php...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/php vendor/bin/phpunit --coverage-html public/coverage
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
PHPUnit 4.8.27 by Sebastian Bergmann and contributors.

[New Thread 0x7fffe6dff700 (LWP 18229)]
[Thread 0x7fffe6dff700 (LWP 18229) exited]
.........
Thread 1 "php" received signal SIGSEGV, Segmentation fault.
xdebug_build_fname_from_oparray (tmp=tmp@entry=0x7fffffff21d0, opa=opa@entry=0x7fffe5a5b0e0) at ./build-7.0/xdebug_code_coverage.c:828
828 ./build-7.0/xdebug_code_coverage.c: No such file or directory.
```
Additional InformationLooks like someone had this issue previously: https://bugs.xdebug.org/view.php?id=1263 That said, the line numbers are slightly different. It's probably the same underlying cause showing up slightly differently.

Also, the PHP version is actually 7.0.11, but the "PHP Version" field here doesn't go up that high.
TagsNo tags attached.
Operating System
PHP Version7.0.5-7.0.9

Relationships

duplicate of 0001331 closedderick Segfault in code coverage 

Activities

mcordingley

2016-10-04 16:07

reporter   ~0003710

Last edited: 2016-10-04 16:09

View 2 revisions

XDebug options currently set:

xdebug.remote_enable=1
xdebug.remote_host=192.168.0.33
xdebug.remote_autostart=1

Commenting them out appears to have no effect on the segfault, though.

derick

2016-10-04 18:05

administrator   ~0003712

I think this is the same issue as 0001331 - which has a link to a GitHub branch that should have a fix. Can you try that one please?

mcordingley

2016-10-04 18:54

reporter   ~0003713

It works. Looks like this is a duplicate of 0001331. :D

derick

2016-10-04 19:21

administrator   ~0003714

Great! I'll close this then (and merge 0001331).

Issue History

Date Modified Username Field Change
2016-10-04 16:05 mcordingley New Issue
2016-10-04 16:07 mcordingley Note Added: 0003710
2016-10-04 16:09 mcordingley Note Edited: 0003710 View Revisions
2016-10-04 18:05 derick Note Added: 0003712
2016-10-04 18:05 derick Assigned To => derick
2016-10-04 18:05 derick Status new => feedback
2016-10-04 18:54 mcordingley Note Added: 0003713
2016-10-04 18:54 mcordingley Status feedback => assigned
2016-10-04 19:21 derick Note Added: 0003714
2016-10-04 19:21 derick Relationship added duplicate of 0001331
2016-10-04 19:21 derick Status assigned => resolved
2016-10-04 19:21 derick Resolution open => duplicate