View Issue Details

IDProjectCategoryView StatusLast Update
0001351XdebugUsage problems (Wrong Results)public2016-12-04 13:17
ReporterRyanNerdAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformLinuxOSLinux MintOS VersionMint 18
Product Version 
Target VersionFixed in Version 
Summary0001351: Error message and segfault
DescriptionCannot accept external Xdebug connection: Cannot evaluate expression 'isset($_SERVER['PHP_IDE_CONFIG'])'

Followed by [1] 26693 segmentation fault php -S localhost:8080
Steps To ReproducePHP 7.2.0-dev (cli) (built: Oct 3 2016 17:48:49) ( ZTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.1.0-dev, Copyright (c) 1998-2016 Zend Technologies
    with Xdebug v2.5.0-dev, Copyright (c) 2002-2016, by Derick Rethans

Running Slimframework with PHP-DI. Looks like somewhere when the DI is trying to resolve is where the crash happens. I'm trying to track down when the segfault occurs (it's deep in either DI or Slimframework).
TagsNo tags attached.
Operating System
PHP Version7.1-dev

Activities

RyanNerd

2016-10-04 23:33

reporter   ~0003715

Looks like the error happens in PHP-DI Container.php at line: 122
       $value = $this->resolveDefinition($definition);

derick

2016-10-05 14:48

administrator   ~0003717

I would need a short reproducible script, not all of DI or the Slim Framework, and exact instructions so that I can reproduce this locally.

derick

2016-11-16 21:17

administrator   ~0003752

ping?

RyanNerd

2016-11-17 20:24

reporter   ~0003760

I was running the dev version of PHP 7.1 and due to different problems I kept running into I switched to the 7.0-dev branch which does not have this issue.
If I can find some time I'll build the 7.1 latest RC and see if this problem persists.

derick

2016-11-22 23:26

administrator   ~0003774

Hi,

please do that - I would like to fix this issue before I release the final
version of 2.5.0.

cheers,
Derick

RyanNerd

2016-12-04 10:40

reporter   ~0003891

I am unable to reproduce this issue. Please Close.

derick

2016-12-04 13:17

administrator   ~0003892

Thanks for checking and double checking!

cheers,
Derick

Issue History

Date Modified Username Field Change
2016-10-04 23:23 RyanNerd New Issue
2016-10-04 23:33 RyanNerd Note Added: 0003715
2016-10-05 14:48 derick Note Added: 0003717
2016-10-05 14:48 derick Assigned To => derick
2016-10-05 14:48 derick Status new => feedback
2016-11-16 21:17 derick Note Added: 0003752
2016-11-17 20:24 RyanNerd Note Added: 0003760
2016-11-17 20:24 RyanNerd Status feedback => assigned
2016-11-22 23:26 derick Note Added: 0003774
2016-11-22 23:26 derick Status assigned => feedback
2016-12-04 10:40 RyanNerd Note Added: 0003891
2016-12-04 10:40 RyanNerd Status feedback => assigned
2016-12-04 13:17 derick Note Added: 0003892
2016-12-04 13:17 derick Status assigned => resolved
2016-12-04 13:17 derick Resolution open => unable to reproduce