View Issue Details

IDProjectCategoryView StatusLast Update
0001358XdebugUsage problems (Wrong Results)public2016-12-11 23:47
ReporterkmettsAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformwindowsOS10OS Versionwin 10
Product Version2.4.1 
Target VersionFixed in Version 
Summary0001358: hello world simple program does not run
Description<?php
    echo "Hello World!";
?>

dies in vs2015 windows 10 php7.0.5

error:
Server Error in '/' Application.

[A]PHP.Core.PhpConfigurationContext cannot be cast to [B]PHP.Core.PhpConfigurationContext. Type A originates from 'PhpNetCore, Version=3.0.0.0, Culture=neutral, PublicKeyToken=0a8e8c4c76728c71' in the context 'Default' at location 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\PhpNetCore\v4.0_3.0.0.0__0a8e8c4c76728c71\PhpNetCore.dll'. Type B originates from 'PhpNetCore, Version=4.0.0.0, Culture=neutral, PublicKeyToken=0a8e8c4c76728c71' in the context 'Default' at location 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\PhpNetCore\v4.0_4.0.0.0__0a8e8c4c76728c71\PhpNetCore.dll'.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.InvalidCastException: [A]PHP.Core.PhpConfigurationContext cannot be cast to [B]PHP.Core.PhpConfigurationContext. Type A originates from 'PhpNetCore, Version=3.0.0.0, Culture=neutral, PublicKeyToken=0a8e8c4c76728c71' in the context 'Default' at location 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\PhpNetCore\v4.0_3.0.0.0__0a8e8c4c76728c71\PhpNetCore.dll'. Type B originates from 'PhpNetCore, Version=4.0.0.0, Culture=neutral, PublicKeyToken=0a8e8c4c76728c71' in the context 'Default' at location 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\PhpNetCore\v4.0_4.0.0.0__0a8e8c4c76728c71\PhpNetCore.dll'.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[InvalidCastException: [A]PHP.Core.PhpConfigurationContext cannot be cast to [B]PHP.Core.PhpConfigurationContext. Type A originates from 'PhpNetCore, Version=3.0.0.0, Culture=neutral, PublicKeyToken=0a8e8c4c76728c71' in the context 'Default' at location 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\PhpNetCore\v4.0_3.0.0.0__0a8e8c4c76728c71\PhpNetCore.dll'. Type B originates from 'PhpNetCore, Version=4.0.0.0, Culture=neutral, PublicKeyToken=0a8e8c4c76728c71' in the context 'Default' at location 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\PhpNetCore\v4.0_4.0.0.0__0a8e8c4c76728c71\PhpNetCore.dll'.]
   PHP.Core.ConfigurationSectionHandler.GetConfig(ApplicationContext appContext, String sectionName) +202
   PHP.Core.Configuration.Load(ApplicationContext appContext) +107
   PHP.Core.Configuration.Reload(ApplicationContext appContext, Boolean reloadFromFile) +73
   PHP.Core.ScriptContext.InitWebRequest(ApplicationContext appContext, HttpContext context) +64
   PHP.Core.RequestContext.Initialize(ApplicationContext appContext) +113
   PHP.Core.RequestContext.Initialize(ApplicationContext appContext, HttpContext context) +356
   PHP.Core.RequestHandler.ProcessRequest(HttpContext context) +200
   System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +188
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +69


Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.6.1586.0
Steps To Reproducehit pf5
TagsNo tags attached.
Operating System
PHP Version7.0.5-7.0.9

Activities

derick

2016-11-16 21:27

administrator   ~0003757

I am not sure why you submitted an issue to Xdebug here. This seems to be Phalanger related, and Xdebug is only for normal PHP, and not Phalanger.

derick

2016-12-11 23:47

administrator   ~0004013

Can't reproduce, and the requested feedback was not provided.

Issue History

Date Modified Username Field Change
2016-10-28 22:26 kmetts New Issue
2016-11-16 21:27 derick Note Added: 0003757
2016-11-16 21:27 derick Assigned To => derick
2016-11-16 21:27 derick Status new => feedback
2016-12-11 23:47 derick Note Added: 0004013
2016-12-11 23:47 derick Status feedback => resolved
2016-12-11 23:47 derick Resolution open => unable to reproduce