View Issue Details

IDProjectCategoryView StatusLast Update
0001359XdebugRemote Debuggingpublic2016-12-11 23:46
ReporterCyberpower678Assigned Toderick 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformPHPStormOSmacOS SierraOS Version10.12.1
Product Version2.4.1 
Target VersionFixed in Version 
Summary0001359: debut.remote_enable not enabled despite set in the INI file
DescriptionI've been trying to get xDebug to allow remote debugging. Logically I went to the ini file and set the xdebug.remote_enable to 1. I also added some additional settings. When I applied them, I found that everything but the remote_enable settings was applied.

I tried everything including re-installing PHP and the extensions and nothing. I'm thinking this is a bug, and a rather big one at that.

Steps To ReproduceInstall PHP and xDebug with Homebrew. Try to configure xDebug in the INI file. A computer restart may be needed.

Load phpinfo.
Additional InformationI picked php54, but this applies to php53, php54, php55, php56, php7, and php71
TagsNo tags attached.
Operating SystemmacOS Sierra
PHP Version5.4.0

Activities

derick

2016-11-16 13:01

administrator   ~0003748

INI parsing is done by PHP, and not by Xdebug. I'm afraid that this is likely a user error. Either you use the wrong php.ini, or you have misspelled something, or you added a non-breaking space or something.

Can you share the php.ini in question, packed up in a .zip or .tar.gz file please? You can add that file to this issue.

derick

2016-12-11 23:46

administrator   ~0004010

Can't reproduce, and the requested feedback was not provided.

Issue History

Date Modified Username Field Change
2016-11-02 04:03 Cyberpower678 New Issue
2016-11-16 13:01 derick Note Added: 0003748
2016-11-16 13:01 derick Assigned To => derick
2016-11-16 13:01 derick Status new => feedback
2016-12-11 23:46 derick Note Added: 0004010
2016-12-11 23:46 derick Status feedback => resolved
2016-12-11 23:46 derick Resolution open => unable to reproduce