View Issue Details

IDProjectCategoryView StatusLast Update
0001363XdebugProfilingpublic2017-02-07 17:08
ReporterfureginAssigned Toderick 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformPHPStorm 2016.2OSMacOSOS Version10.12.1 (Sierra)
Product Version2.5.0RC1 
Target VersionFixed in Version 
Summary0001363: Crash on debug yii2 console script
DescriptionWithout breakpoints - works success.

But with breakpoints - crash.
 
Crash with error in console:

/usr/local/Cellar/php71/7.1.0-rc.1_4/bin/php -dxdebug.remote_enable=1 -dxdebug.remote_mode=req -dxdebug.remote_port=9001 -dxdebug.remote_host=127.0.0.1 /Volumes/Data/www/yii test/task-fill

Process finished with exit code 139 (interrupted by signal 11: SIGSEGV)
Steps To Reproducerun any yii2 console command, example: `php yii test/test`

May be php autoloader crashed.
TagsNo tags attached.
Operating SystemMacOS
PHP Version7.1-dev

Relationships

has duplicate 0001364 resolvedderick Crash on debug yii2 console script 

Activities

furegin

2016-11-16 12:00

reporter  

2016-11-16_16-58-08.png (98,809 bytes)
2016-11-16_16-58-08.png (98,809 bytes)

derick

2016-11-16 12:52

administrator   ~0003745

Can you please install "gdb", and then retry with the following (on the shell):

export USE_ZEND_ALLOC=0
gdb --args /usr/local/Cellar/php71/7.1.0-rc.1_4/bin/php -dxdebug.remote_enable=1 -dxdebug.remote_mode=req -dxdebug.remote_port=9001 -dxdebug.remote_host=127.0.0.1 /Volumes/Data/www/yii test/task-fill


And then in the GDB prompt:

run

And when it crashes/bails out, run:

bt full

And add the output as a file to this report.

derick

2016-11-22 23:26

administrator   ~0003777

Ping?

furegin

2016-11-23 05:41

reporter   ~0003783

ok)

derick

2016-11-23 10:15

administrator   ~0003785

(Changing the status back to feedback until the requested info has been given)

furegin

2016-11-24 14:16

reporter   ~0003790

run:
gdb --args /usr/local/Cellar/php71/7.1.0-rc.1_4/bin/php -dxdebug.remote_enable=1 -dxdebug.remote_mode=req -dxdebug.remote_port=9001 -dxdebug.remote_host=127.0.0.1 /Volumes/Data/www/me/taskfall.net/yii test/task-fill

output:
Reading symbols from /usr/local/Cellar/php71/7.1.0-rc.1_4/bin/php...(no debugging symbols found)...done.
(gdb)
(gdb) run
Starting program: /usr/local/Cellar/php71/7.1.0-rc.1_4/bin/php -dxdebug.remote_enable=1 -dxdebug.remote_mode=req -dxdebug.remote_port=9001 -dxdebug.remote_host=127.0.0.1 /Volumes/Data/www/me/taskfall.net/yii test/task-fill
[New Thread 0x1403 of process 34869]
warning: unhandled dyld version (15)
[Inferior 1 (process 34869) exited normally]
(gdb) bt full
No stack.
(gdb)


Without Breakpoints into php-script - run fine!
But if script has breakpoints - crashed!

I don't know how stay breakpoints in gdb in php-script

derick

2016-12-04 16:46

administrator   ~0003919

You should set the breakpoints in a similar way as you would normally do this. GDB does not come into play here, it is merely helpful for when the crash happens. If you enable the "listen for debugging connections in PhpStorm", then PhpStorm should allow you to set breakpoints as normal. Can you try that?

derick

2017-01-03 18:47

administrator   ~0004125

Ping?

derick

2017-02-07 17:08

administrator   ~0004199

I am closing this, as I can't reproduce this, and the requested feedback has not been given. Please feel free to reopen this if you can provide more information as requested.

Issue History

Date Modified Username Field Change
2016-11-16 12:00 furegin New Issue
2016-11-16 12:00 furegin File Added: 2016-11-16_16-58-08.png
2016-11-16 12:52 derick Note Added: 0003745
2016-11-16 12:52 derick Assigned To => derick
2016-11-16 12:52 derick Status new => feedback
2016-11-16 12:53 derick Relationship added has duplicate 0001364
2016-11-22 23:26 derick Note Added: 0003777
2016-11-23 05:41 furegin Note Added: 0003783
2016-11-23 05:41 furegin Status feedback => assigned
2016-11-23 10:15 derick Note Added: 0003785
2016-11-23 10:15 derick Status assigned => feedback
2016-11-24 14:16 furegin Note Added: 0003790
2016-11-24 14:16 furegin Status feedback => assigned
2016-12-04 16:46 derick Note Added: 0003919
2016-12-04 16:46 derick Status assigned => feedback
2017-01-03 18:47 derick Note Added: 0004125
2017-02-07 17:08 derick Note Added: 0004199
2017-02-07 17:08 derick Status feedback => resolved
2017-02-07 17:08 derick Resolution open => unable to reproduce