View Issue Details

IDProjectCategoryView StatusLast Update
0001402XdebugRemote Debuggingpublic2017-03-01 12:27
ReporterihorslAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0001402: Setting of conditional breakpoint fails without linenumber
DescriptionCan't set conditional breakpoint without -n lineno

breakpoint_set -i transaction_id -t conditional -f "file:///mnt/vmware/Z_HOME/Work/softdevel/2017/local-kidsale_ru/local_html/wp-content/plugins/nice-login-register-widgetindex.php/pw-login-widget.php" -- base64($a>$b)



In documentation is described, that line number is not required for conditional breakpoints
Additional Informationbreakpoint_set -i transaction_id -t conditional -f "file:///mnt/vmware/Z_HOME/Work/softdevel/2017/local-kidsale_ru/local_html/wp-content/plugins/nice-login-register-widgetindex.php/pw-login-widget.php" -- base64($a>$b)


311 <?xml version="1.0" encoding="iso-8859-1"?>
<response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="transaction_id" status="starting" reason="ok"><error code="3"><message><![CDATA[invalid or missing options]]></message></error></response>
TagsNo tags attached.
Operating System
PHP Version5.6.25-5.6.29

Relationships

duplicate of 0000513 acknowledgedderick DBGP: conditional breakpoint still require a line number 

Activities

derick

2017-03-01 12:27

administrator   ~0004224

Duplicate of 513.

Issue History

Date Modified Username Field Change
2017-03-01 12:23 ihorsl New Issue
2017-03-01 12:27 derick Note Added: 0004224
2017-03-01 12:27 derick Relationship added duplicate of 0000513
2017-03-01 12:27 derick Status new => resolved
2017-03-01 12:27 derick Resolution open => duplicate
2017-03-01 12:27 derick Assigned To => derick