View Issue Details

IDProjectCategoryView StatusLast Update
0001403XdebugCode Coveragepublic2017-03-02 16:19
ReporterderickAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.5.1 
Target Version2.5.2Fixed in Version2.5.2 
Summary0001403: Code coverage does not cover BIND_STATIC
Description<?php
use PHPUnit\Framework\TestCase;

// Because it is "line based" and not statement base coverage
// the variables for "use" are shown as not covered.
$someObject->reduce(function () use (
    $outerItem,
    $anotherOuterItem
) {
   return false;
});


The lines with $outerItem and $anotherOuterItem are never covered.
TagsNo tags attached.
Operating System
PHP Version7.1.0-7.1.4

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2017-03-02 16:05 derick New Issue
2017-03-02 16:05 derick Status new => assigned
2017-03-02 16:05 derick Assigned To => derick
2017-03-02 16:19 derick Status assigned => closed
2017-03-02 16:19 derick Resolution open => fixed
2017-03-02 16:19 derick Fixed in Version => 2.5.2