View Issue Details

IDProjectCategoryView StatusLast Update
0001435XdebugRemote Debuggingpublic2018-01-29 21:50
ReporterqwertyzwAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityunable to reproduce
Status resolvedResolutionunable to reproduce 
PlatformUbuntu 16.04OSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001435: Xdebug 2.5.4 (branch xdebug_2_5)
DescriptionHi Derrick,

Just logging a crash I ran into.

I have an ubuntu crash file with an embedded core dump (see https://wiki.ubuntu.com/DebuggingProgramCrash to open coredump)

Long story short line 2746 of xdebug.c caused the segfault (commit 2862119365681eeb1dc6ca8b3777a36a9fa17e94)

I feel .handler->remote_breakpoint is probably what caused the violation
Steps To ReproduceI couldn't unfortunately, it happened the first time after restarting my box and I couldn't reproduce it after.
TagsNo tags attached.
Operating System
PHP Version7.1.0-7.1.4

Activities

qwertyzw

2017-05-03 02:39

reporter  

_usr_bin_php7.1.1000.crash (1,343,890 bytes)

qwertyzw

2017-05-03 02:41

reporter   ~0004334

It happened while I was running tests

derick

2017-12-16 17:26

administrator   ~0004512

Does this still happen? If so, can you provide a full set of instructions for me to try to reproduce this?

derick

2018-01-01 20:46

administrator   ~0004533

Ping?

derick

2018-01-29 21:50

administrator   ~0004584

Can't reproduce this, and no feedback provided.

Issue History

Date Modified Username Field Change
2017-05-03 02:39 qwertyzw New Issue
2017-05-03 02:39 qwertyzw File Added: _usr_bin_php7.1.1000.crash
2017-05-03 02:41 qwertyzw Note Added: 0004334
2017-12-16 17:26 derick Note Added: 0004512
2017-12-16 17:26 derick Assigned To => derick
2017-12-16 17:26 derick Status new => feedback
2018-01-01 20:46 derick Note Added: 0004533
2018-01-29 21:50 derick Note Added: 0004584
2018-01-29 21:50 derick Status feedback => resolved
2018-01-29 21:50 derick Resolution open => unable to reproduce