View Issue Details

IDProjectCategoryView StatusLast Update
0001438XdebugUsage problems (Wrong Results)public2018-01-01 20:48
ReporterjlaryszAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformIntel i7 / Asus motherboardOSWindows OS Version10 workstation
Product Version2.5.3 
Target VersionFixed in Version 
Summary0001438: xdebug and phpmyadmin do not work together on Windows 10
DescriptionI am using wampserver 64-bit version version 3.0 ( download file wampserver3.0.6_x64_apache2.4.23_mysql5.7.14_php5.6.25-7.0.10.exe ) with phpmyadmin 4.7.0, and xedit dll "php_xdebug-2.5.3-5.6-vc11-x86_64.dll".

I cannot execute any SQL queries in phpmyadmin when xedit is configured. The page flashes a popup saying "Loading" and stays there. It's as if the code hit a breakpoint, but there is no way to make it move forward. I have tried 3 versions of phpmyadmin - all the same. Removing xedit from php.ini restores the functionality of phpmyadmin.

Command line mysql queries work OK.
Steps To Reproduce1. Configure xedit on any Windows 10 machine running Apache (wamp640 and phpmyadmin.

2: Open the phpmyadmin page and then open a database

3: Browse any table

4: Go to "Edit inline" and add a "where" condition to the query

5: Click the "Go" button
TagsNo tags attached.
Operating SystemWindows 10
PHP Version7.1.0-7.1.4

Activities

nicholasjohn16

2017-09-28 02:22

reporter   ~0004432

Last edited: 2017-09-28 02:24

View 2 revisions

I can confirm this issue and am experiencing it myself. phpMyAdmin becomes largely unusable due to this. Disabling remote_autostart and profiler_enable didn't stop the issue.

Apache 2.4.9
PHP 5.6.24
phpMyAdmin 4.7.4

derick

2017-12-17 14:21

administrator   ~0004515

Is this still an issue with xdebug 2.5.5?

nicholasjohn16

2017-12-18 23:16

reporter   ~0004522

The issues seems to have resolved with 2.5.5.

derick

2018-01-01 20:48

administrator   ~0004536

Perfect, let me close this then.

Issue History

Date Modified Username Field Change
2017-05-13 13:41 jlarysz New Issue
2017-09-28 02:22 nicholasjohn16 Note Added: 0004432
2017-09-28 02:24 nicholasjohn16 Note Edited: 0004432 View Revisions
2017-12-17 14:21 derick Note Added: 0004515
2017-12-17 14:21 derick Assigned To => derick
2017-12-17 14:21 derick Status new => feedback
2017-12-18 23:16 nicholasjohn16 Note Added: 0004522
2018-01-01 20:48 derick Note Added: 0004536
2018-01-01 20:48 derick Status feedback => resolved
2018-01-01 20:48 derick Resolution open => no change required