View Issue Details

IDProjectCategoryView StatusLast Update
0001505XdebugUsage problems (Wrong Results)public2018-01-23 16:47
ReporterrtsikmaAssigned Toderick 
PriorityimmediateSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Platformx64OSWindowsOS Version10
Product Version2.6.0beta1 
Target VersionFixed in Version 
Summary0001505: CLI has stopped working error when xdebug extension is loaded
DescriptionWhen attempting to start PHP with the xdebug extension and my own created extension, a "CLI has stopped working error" is displayed.
Steps To ReproduceRun php -i with a custom extension
Additional InformationA crash dump is available for this issue here:
https://drive.google.com/file/d/1L-YOpKlnNM9m1BEtxYcxGKoNLScFHgFx/view?usp=sharing

This is on a 64 bit Windows 10 PC, running a 32-bit PHP.

This PHP install has a custom extension extension
TagsNo tags attached.
Operating SystemWindows 10
PHP Version7.2.0-7.2.4

Activities

derick

2017-12-29 23:14

administrator   ~0004528

Hi,

If you want me to have a look at this, I need to be able to reproduce this on a Linux platform. That means, I need to have your extension's source code.
I can't go on just a Windows crash dump.

cheers,
Derick

rtsikma

2017-12-29 23:19

reporter   ~0004529

Considering that the entension is proprietary code from the company I work for, that may prove difficult.

What I get from the debug call stack is this:

[Inline Frame] php7.dll!zend_mm_alloc_small(_zend_mm_heap *) Line 1273
[Inline Frame] php7.dll!zend_mm_alloc_heap(_zend_mm_heap * heap, unsigned int) Line 1344
[Inline Frame] php7.dll!_emalloc(unsigned int) Line 2433
php7.dll!_array_init(_zval_struct * arg, unsigned int size) Line 1090
[Inline Frame] php7.dll!php_register_server_variables() Line 626
php7.dll!php_auto_globals_create_server(_zend_string * name) Line 780
php7.dll!zend_is_auto_global_str(char * name, unsigned int len) Line 1653
[Inline Frame] php_xdebug.dll!xdebug_init_auto_globals() Line 1083
php_xdebug.dll!zm_activate_xdebug(int type, int module_number) Line 1186
php7.dll!zend_activate_modules() Line 2600
php7.dll!php_request_startup() Line 1697
php.exe!do_cli(int argc, char * * argv) Line 728
php.exe!main(int argc, char * * argv) Line 1406

derick

2017-12-29 23:22

administrator   ~0004530

Sorry, I can't help then. Feel free to reach out privately in case you can provide this privately — email is at https://xdebug.org/support.php#email

rtsikma

2018-01-23 16:28

reporter   ~0004573

In case you were curious about this, I was able to resolve this issue. The problem was a zend_string pointer not being properly freed (efree() was called on the zend_string->val instead of calling zend_string_release().

When I updated to PHP 7.2.1 the crash location changed from inside the xdebug extension to the mysqldn extension. Fun times :)

derick

2018-01-23 16:47

administrator   ~0004574

OK. Good to know it wasn't in Xdebug then. Cheers!

Issue History

Date Modified Username Field Change
2017-12-29 23:06 rtsikma New Issue
2017-12-29 23:14 derick Note Added: 0004528
2017-12-29 23:14 derick Assigned To => derick
2017-12-29 23:14 derick Status new => feedback
2017-12-29 23:19 rtsikma Note Added: 0004529
2017-12-29 23:19 rtsikma Status feedback => assigned
2017-12-29 23:22 derick Note Added: 0004530
2017-12-29 23:22 derick Status assigned => resolved
2017-12-29 23:22 derick Resolution open => unable to reproduce
2018-01-23 16:28 rtsikma Note Added: 0004573
2018-01-23 16:47 derick Note Added: 0004574