View Issue Details

IDProjectCategoryView StatusLast Update
0001523XdebugInstallationpublic2019-01-23 20:37
ReporterraffaelloAssigned Toderick 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformOSCentOS Linux 6.9OS Version
Product Version2.6.0 
Target VersionFixed in Version 
Summary0001523: Cannot Install
DescriptionHi,
I'm trying to install Xdebug for the first time.
I've followed strictly the steps of the installation wizard but when I launch the "make test" I receive the following error:
Failed loading /xdebug-2.6.0/modules/xdebug.so: /xdebug-2.6.0/modules/xdebug.so: undefined symbol: php_base64_decode

I get it also when I launch php -v
In the next Additional Information I paste the result of the make test.
Additional InformationBuild complete.
Don't forget to run 'make test'.

Failed loading /xdebug-2.6.0/modules/xdebug.so: /xdebug-2.6.0/modules/xdebug.so: undefined symbol: php_base64_decode
Failed loading /xdebug-2.6.0/modules/xdebug.so: /xdebug-2.6.0/modules/xdebug.so: undefined symbol: php_base64_decode

=====================================================================
PHP : /usr/bin/php
PHP_SAPI : cli
PHP_VERSION : 7.2.2
ZEND_VERSION: 3.2.0
PHP_OS : Linux - Linux cloudRG01 2.6.32-696.20.1.el6.x86_64 #1 SMP Fri Jan 26 17:51:45 UTC 2018 x86_64
INI actual : /xdebug-2.6.0/tmp-php.ini
More .INIs :
CWD : /xdebug-2.6.0
Extra dirs :
VALGRIND : Not used
=====================================================================
TIME START 2018-01-31 18:24:03
=====================================================================
No tests were run.
TagsNo tags attached.
Operating SystemCentOS Linux 6.9
PHP Version7.2.0-7.2.4

Activities

derick

2018-02-01 11:17

administrator   ~0004590

I can see some changes in PHP 7.2 about this, but this works on many other Linux platforms that I have tried. I'm curious to know what is different on your platform, so can you please list:

- whether you use PHP from a centos package, or whether you've compiled it yourself. If the former, the exact version of the php and php-devel packages. If the latter, the version of PHP and possibly related ./configure lines.
- the output of "gcc --version"
- How exactly you compiled Xdebug - from download (manual, or pecl) to getting the error in your report

And attach the full output of ./configure and make to this ticket please.

derick

2019-01-23 20:37

administrator   ~0004847

I am closing this ticket, as I can not reproduce this, and the requested feedback was not provided. Please reopen if you have the additional information that I've asked for.

cheers,
Derick

Issue History

Date Modified Username Field Change
2018-01-31 18:38 raffaello New Issue
2018-02-01 11:17 derick Note Added: 0004590
2018-02-01 11:17 derick Assigned To => derick
2018-02-01 11:17 derick Status new => feedback
2019-01-23 20:37 derick Note Added: 0004847
2019-01-23 20:37 derick Status feedback => resolved
2019-01-23 20:37 derick Resolution open => unable to reproduce