View Issue Details

IDProjectCategoryView StatusLast Update
0001553XdebugStep Debuggingpublic2021-04-14 16:06
Reporterspajak Assigned Toderick  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformLinuxOSDebianOS Versionsid
Product Version2.6.0 
Summary0001553: Debugger always starts
DescriptionIf you set remote_host throu environment variable like so:
XDEBUG_CONFIG=remote_host=192.168.0.221
xdebug starts debug session on every request, regardless GET/POST params or cookie presence. This is in conflict with default behavior when the same remote_host is set in php.ini file, which is to trigger debugging only when special GET/POST param or cookie is present.
Steps To Reproduce1. Install nginx + php7.0-fpm + xdebug-2.6.0

2. Set environment variable XDEBUG_CONFIG=remote_host=<MY_IP>

3. Make a request without any parameters or cookies. See the response with Set-Cookie: XDEBUG_SESSION=www-data; or something similar, which triggers debugger
TagsNo tags attached.
Operating SystemDebian sid
PHP Version7.0.25-7.0.29

Activities

derick

2021-03-17 09:33

administrator   ~0005755

Is this issue still relevant to you with Xdebug 3?

derick

2021-04-14 16:06

administrator   ~0005835

Closing this, as it is missing requested feedback.

Issue History

Date Modified Username Field Change
2018-05-25 17:19 spajak New Issue
2020-03-12 16:33 derick Category Remote Debugging => Step Debugging
2021-03-17 09:33 derick Assigned To => derick
2021-03-17 09:33 derick Status new => feedback
2021-03-17 09:33 derick Note Added: 0005755
2021-04-14 16:06 derick Status feedback => closed
2021-04-14 16:06 derick Resolution open => unable to reproduce
2021-04-14 16:06 derick Note Added: 0005835