View Issue Details

IDProjectCategoryView StatusLast Update
0001595XdebugRemote Debuggingpublic2018-12-27 18:36
ReportermariskayAssigned Toderick 
PriorityhighSeverityblockReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Version2.6.0 
Target VersionFixed in Version 
Summary0001595: Xdebug stops at breakpoint but cannot continue step by step
DescriptionAll was working perfectly but today after an update I cannot use Xdebug as normal. Yes, it stops @ breakpoints but cannot continue with step by step mode (f10) in VScode.

These are settings in launch.json:

        "name": "Listen for XDebug",
        "type": "php",
        "request": "launch",
        "port": 9000,
        "localSourceRoot": "/home/gfxking/Desktop/CurrentDev/SCRIPTS/DEV",
        "serverSourceRoot": "/var/www/vhosts/dev/httpdocs"
        "name": "Launch currently open script",
        "type": "php",
        "request": "launch",
        "program": "${file}",
        "cwd": "${fileDirname}",
        "port": 9000
Server output:

[root@server ~]# /opt/plesk/php/7.1/bin/php -vPHP 7.1.25 (cli) (built: Dec 7 2018 12:12:21) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from (unconfigured) v10.2.1, Copyright (c) 2002-2018, by ionCube Ltd.
    with Zend OPcache v7.1.25, Copyright (c) 1999-2018, by Zend Technologies
    with Xdebug v2.5.0, Copyright (c) 2002-2016, by Derick Rethans
50-xdebug.ini on server:
Maybe someone else has experienced this and knows what has suddenly changed .. today?
TagsNo tags attached.
Operating SystemCentos Server / Debian coding environment
PHP Version7.1.0-7.1.4



2018-12-23 21:07

administrator   ~0004777

I see you have the following in php.ini:

Which means you have a xdebug.log file in /ar/log. Can you remove it, and then do *one* debugging session of one script? And then attach the file. Bonus points for doing this with a single script without any dependencies (including composer packages).


2018-12-23 22:24

reporter   ~0004782

Please disregard this, it turned out the issue was caused my VSCode having a mysqli function in debug variable watch list. As soon as it was removed - all worked again as expected. Thanks.


2018-12-27 18:36

administrator   ~0004787

OK, no problem. I'm closing this then.

Issue History

Date Modified Username Field Change
2018-12-12 13:15 mariskay New Issue
2018-12-23 21:07 derick Note Added: 0004777
2018-12-23 21:07 derick Assigned To => derick
2018-12-23 21:07 derick Status new => feedback
2018-12-23 22:24 mariskay Note Added: 0004782
2018-12-23 22:24 mariskay Status feedback => assigned
2018-12-27 18:36 derick Note Added: 0004787
2018-12-27 18:36 derick Status assigned => resolved
2018-12-27 18:36 derick Resolution open => unable to reproduce