View Issue Details

IDProjectCategoryView StatusLast Update
0001600XdebugRemote Debuggingpublic2019-02-01 15:23
ReportervmorozovAssigned Toderick 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
PlatformOSMac OSOS Version
Product Version2.7.0beta1 
Target VersionFixed in Version 
Summary0001600: Crashes while trying to debug laravel 5.7 app
Description/usr/local/bin/php -S localhost:8000 -t public -d zend_extension=/usr/local/Cellar/php/7.3.0/pecl/20180731/xdebug.so

Process finished with exit code 139 (interrupted by signal 11: SIGSEGV)
Steps To Reproduceplace breakpoint in controller method
start php dev server
server crushes
TagsNo tags attached.
Operating System
PHP Version7.3.0

Relationships

duplicate of 0001583 closedderick Xdebug crashes when OPcache's compact literals optimisation is on 

Activities

derick

2018-12-23 21:08

administrator   ~0004778

Can you run the following on the shell:

export USE_ZEND_ALLOC=0
gdb --args /usr/local/bin/php -S localhost:8000 -t public -d zend_extension=/usr/local/Cellar/php/7.3.0/pecl/20180731/xdebug.so

Then on the (gdb) prompt type "run". Then request a web site on localhost:8000. When there is a crash in GDB (it should say segmentation fault), type "bt full", and attach that file.

vmorozov

2018-12-26 08:14

reporter   ~0004784

This is the command output. I think it didn`t work properly.

gdb --args /usr/local/bin/php -S localhost:8000 -t public -d zend_extension=/usr/local/Cellar/php/7.3.0/pecl/20180731/xdebug.so

GNU gdb (GDB) 8.2.1
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-apple-darwin18.2.0".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
--Type <RET> for more, q to quit, c to continue without paging--
Type "apropos word" to search for commands related to "word"...
BFD: /usr/local/Cellar/php/7.3.0/bin/php: unknown load command 0x32
BFD: /usr/local/Cellar/php/7.3.0/bin/php: unknown load command 0x32
"/usr/local/bin/php": not in executable format: file format not recognized
(gdb) run
Starting program: -S localhost:8000 -t public -d zend_extension=/usr/local/Cellar/php/7.3.0/pecl/20180731/xdebug.so
No executable file specified.
Use the "file" or "exec-file" command.
(gdb) bt full
No stack.
(gdb)

derick

2018-12-27 18:45

administrator   ~0004788

GDB doesn't seem to understand your binary. It seems to be related to some changes in OSX, so I'm not sure what I can do about that :-/

From what I googled, it's because it's not "codesigned" or whatever that is. There are instructions at https://stackoverflow.com/questions/52699661/macos-mojave-how-to-achieve-codesign-to-enable-debugging-gdb on how to fix that.

derick

2019-02-01 15:23

administrator   ~0004859

I am going to guess that this is the same issue as 0001583, but that is going to be a guess as no complete backtrace has been produced. Please try the upcoming 2.7.0RC1 release (out in the next few hours), and see if it solves the problem. If not, please reopen this issue, and attach a complete backtrace.

Issue History

Date Modified Username Field Change
2018-12-21 09:44 vmorozov New Issue
2018-12-23 21:08 derick Note Added: 0004778
2018-12-23 21:08 derick Assigned To => derick
2018-12-23 21:08 derick Status new => feedback
2018-12-26 08:14 vmorozov Note Added: 0004784
2018-12-26 08:14 vmorozov Status feedback => assigned
2018-12-27 18:45 derick Note Added: 0004788
2018-12-27 18:45 derick Status assigned => feedback
2019-02-01 15:23 derick Note Added: 0004859
2019-02-01 15:23 derick Relationship added duplicate of 0001583
2019-02-01 15:23 derick Status feedback => resolved
2019-02-01 15:23 derick Resolution open => duplicate