View Issue Details

IDProjectCategoryView StatusLast Update
0001640XdebugStep Debuggingpublic2021-03-17 09:32
Reporterderick Assigned Toderick  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionduplicate 
Summary0001640: Add return value to break reply for function exit breakpoints
DescriptionCurrently it is not easily possible to see the return values of functions while remote debugging. Function tracing already supports showing the return value of functions, and this value could also be added to the DBGp reply when a function breakpoint hits.

This request came through a twitter conversion at https://twitter.com/rikwillems/status/1098146052631334912.
TagsNo tags attached.
Operating System
PHP Version7.3.0-7.3.1

Relationships

duplicate of 0001591 closedderick Augment step_* responses to include returned values 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-02-24 17:43 derick New Issue
2020-03-12 16:14 derick Severity minor => feature
2020-03-12 16:33 derick Category Remote Debugging => Step Debugging
2021-03-17 09:32 derick Assigned To => derick
2021-03-17 09:32 derick Status new => resolved
2021-03-17 09:32 derick Resolution open => duplicate
2021-03-17 09:32 derick Relationship added duplicate of 0001591