View Issue Details

IDProjectCategoryView StatusLast Update
0001655XdebugProfilingpublic2019-07-29 13:06
ReportercaffeinejoltAssigned Toderick 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.7.1 
Target Version2.8.0devFixed in Version 
Summary0001655: 2 profile/cachegrind files created when auto_prepend_file in use
DescriptionA single request ends up with two cachegrind files getting created if auto_prepend_file is in use. Older versions of xdebug did not do this (i.e. 2.4.x etc.).

Not a huge deal at all - in fact - it can stay that way for all I care since beforehand in webgrind, all cachegrind files got created and identified themselves as the auto-prepend file.

I am simply passing this along since I just upgraded from 2.4 to 2.7.1 and noticed this - and I did not see it mentioned in docs.

This is more of informational feedback than an issue - just letting you know.
TagsNo tags attached.
Operating System
PHP Version7.3.2-7.3.4

Relationships

duplicate of 0001589 closedderick function names used in auto_prepend_file missing from main cachegrind file 
has duplicate 0001669 resolvedderick Cannot log anything if there is class destructor. 

Activities

caffeinejolt

2019-04-10 23:25

reporter   ~0004989

same thing for trace files - as you may have guessed

derick

2019-07-29 13:06

administrator   ~0005096

But fixes in GIT now.

Issue History

Date Modified Username Field Change
2019-04-10 23:14 caffeinejolt New Issue
2019-04-10 23:25 caffeinejolt Note Added: 0004989
2019-06-28 11:48 derick Relationship added has duplicate 0001669
2019-06-28 11:48 derick Target Version => 2.8.0dev
2019-07-29 13:06 derick Assigned To => derick
2019-07-29 13:06 derick Status new => resolved
2019-07-29 13:06 derick Resolution open => duplicate
2019-07-29 13:06 derick Note Added: 0005096
2019-07-29 13:06 derick Relationship added duplicate of 0001589