View Issue Details

IDProjectCategoryView StatusLast Update
0001659XdebugProfilingpublic2019-06-28 11:42
ReporterAmegatronAssigned Toderick 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0001659: Allow specifying profile's filename from GET/POST/HEADER vars.
DescriptionWhen triggering profiler it would be very convinient if we could also specify output filename using request variables.

It could solve at least two problems:
1) main problem: if there are already some profiles in the output folder before profiling, you can get lost among previous profiles. But when you explicitly sepcify the file-name, you know what file to open then.
2) it could theoretically ease automating the profiling process (for example, a simple macros for manual profile analysis: launch the profiler and then auto-open the profile). For example, such macros could theoretically be implemented inside IDE's (like there is now Run/Debug buttons in PhpStorm, there could another button be added - "Profile", which would auto-open the generated profile).

*) I know that XDebug adds a response-header telling about the generated filename, which actually solves the problems above, but that requires somewhat analyzing it [response], so adding a new request variable for the filename could ease the process.
**) For securiy reasons, I think it would be wiser to allow only spefifying additional param for "profiler_output_name", not the whole filename (I mean specifying an additional "%"-placeholder). In this case one could strictly forbid getting filenames from request by just not adding this placeholder to the pattern, no additional configuration variables are needed.
Tagsprofiling
Operating System
PHP Version7.3.0-7.3.1

Activities

derick

2019-06-28 11:42

administrator   ~0005046

Hi,

I'm closing this as "Won't Fix", because the feature that you mention in your report that "actually solves it" was created for a similar request to yours. Due to security reasons, and trying not to clutter the Xdebug API with multiple ways to obtain the same result, I won't be adding this.

thanks for your time to report this though!

cheers,
Derick

Issue History

Date Modified Username Field Change
2019-04-23 17:49 Amegatron New Issue
2019-04-23 17:49 Amegatron Tag Attached: profiling
2019-06-28 11:42 derick Assigned To => derick
2019-06-28 11:42 derick Status new => resolved
2019-06-28 11:42 derick Resolution open => won't fix
2019-06-28 11:42 derick Note Added: 0005046