View Issue Details

IDProjectCategoryView StatusLast Update
0000167XdebugUsage problems (Wrong Results)public2006-08-19 13:38
ReporterXueferAssigned Toderick 
PrioritynoneSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000167: [php4] crashed with user session handler
Descriptioni guess the same fix is done for php5+ by ZE2's post_deactive func, but it's not enough for php4
patch here

cvs diff: Diffing .
Index: xdebug.c
===================================================================
RCS file: /repository/xdebug/xdebug.c,v
retrieving revision 1.298
diff -u -r1.298 xdebug.c
--- xdebug.c 10 Feb 2006 14:44:55 -0000 1.298
+++ xdebug.c 14 Feb 2006 04:41:59 -0000
@@ -1165,6 +1165,12 @@
    int function_nr = 0;
    xdebug_llist_element *le;
 
+ if (XG(stack) == NULL) {
+ /* in request shutdown */
+ xdebug_old_execute(op_array TSRMLS_CC);
+ return;
+ }
+
    if (XG(level) == 0) {
        /* Set session cookie if requested */
        if (
@@ -1339,6 +1345,12 @@
    int do_return = (XG(do_trace) && XG(trace_file));
    int function_nr = 0;
 
+ if (XG(stack) == NULL) {
+ /* in request shutdown */
+ execute_internal(current_execute_data, return_value_used TSRMLS_CC);
+ return;
+ }
+
    XG(level)++;
    if (XG(level) == XG(max_nesting_level)) {
        php_error(E_ERROR, "Maximum function nesting level of '%ld' reached, aborting!", XG(max_nesting_level));
TagsNo tags attached.
Operating System
PHP Version4.3.11

Activities

derick

2006-02-21 22:35

administrator   ~0000372

Do you have a reproducing script with this perhaps?

Xuefer

2006-03-10 12:20

reporter   ~0000383

<?php
function a()
{
    b();
}
function b()
{
    $dummy = 1;
}

session_set_save_handler('a', 'a', 'a', 'a', 'a', 'a');
session_start();
?>

tested when xdebug is put as php-src/ext/xdebug, buildconf, configure --enable-xdebug
well... the doc and the source said one should load it as zend extension, but it looks fine with the patch.

Issue History

Date Modified Username Field Change
2006-02-14 05:43 Xuefer New Issue
2006-02-21 22:35 derick Note Added: 0000372
2006-02-21 22:35 derick Priority normal => none
2006-02-21 22:35 derick Status new => feedback
2006-03-10 12:20 Xuefer Note Added: 0000383
2006-08-19 13:38 derick Status feedback => resolved
2006-08-19 13:38 derick Resolution open => unable to reproduce
2006-08-19 13:38 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)