View Issue Details

IDProjectCategoryView StatusLast Update
0001679XdebugCode Coveragepublic2019-07-12 16:30
ReporterderickAssigned Toderick 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.7.2 
Target Version2.8.0devFixed in Version2.8.0dev 
Summary0001679: FETCH_STATIC_PROP_FUNC_ARG is not overloaded
DescriptionWith the code:

    /** @noinspection MagicMethodsValidityInspection */
    public function __phpunit_getInvocationMocker(): InvocationMocker
    {
        if ($this->__phpunit_invocationMocker === null) {
            $this->__phpunit_invocationMocker = new InvocationMocker(
                static::$__phpunit_configurableMethods,
                $this->__phpunit_returnValueGeneration
            );
        }

        return $this->__phpunit_invocationMocker;
    }


The <code>static::$__phpunit_configurableMethods</code> is not covered, because FETCH_STATIC_PROP_FUNC_ARG is not overloaded:

  68     5    >   EXT_STMT
         6        NEW                                              $0      :-21
         7        EXT_FCALL_BEGIN
         8        CHECK_FUNC_ARG
  69     9        FETCH_STATIC_PROP_FUNC_ARG   unknown             $1      '__phpunit_configurableMethods'
        10        SEND_FUNC_ARG                                            $1
        11        CHECK_FUNC_ARG


derick@singlemalt:~/dev/php/derickr-xdebug$ grep -r FETCH_OBJ_FUNC_ARG
xdebug.c:       XDEBUG_SET_OPCODE_OVERRIDE_COMMON(ZEND_FETCH_OBJ_FUNC_ARG);
xdebug.c:           zend_set_user_opcode_handler(ZEND_FETCH_OBJ_FUNC_ARG, NULL);
derick@singlemalt:~/dev/php/derickr-xdebug$ grep -r FETCH_STATIC_PROP_FUNC_ARG
derick@singlemalt:~/dev/php/derickr-xdebug$

TagsNo tags attached.
Operating System
PHP Version7.3.5-7.3.9

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-07-09 11:16 derick New Issue
2019-07-12 16:30 derick Assigned To => derick
2019-07-12 16:30 derick Status new => closed
2019-07-12 16:30 derick Resolution open => fixed
2019-07-12 16:30 derick Fixed in Version => 2.8.0dev