View Issue Details

IDProjectCategoryView StatusLast Update
0001696XdebugRemote Debuggingpublic2019-09-06 11:27
ReporterdinuAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version2.7.2 
Target VersionFixed in Version 
Summary0001696: xdebug also stops on hardlinked files?
DescriptionI have 2 repositories (let's say "a","b"), cloned using mercurial, each with identical file structures. As far as I know, mercurial uses a copy-on-write scheme to speed up replication, locally.

What happens is that, having set a breakpoint in a/foo.php, it also breaks in b/foo.php . It's not the end of the world, but it can be quite confusing.
TagsNo tags attached.
Operating System
PHP Version7.2.15-7.2.19

Activities

derick

2019-08-20 09:07

administrator   ~0005118

Xdebug uses the operating system's "realpath" facilities, just like PHP has. I didn't think that it would recognise different hard linked paths, but it should have an effect with soft-linked paths. Can you add the information that's requested at https://xdebug.org/support.php#remote so that I can try and reproduce?

derick

2019-09-06 11:27

administrator   ~0005136

I can't reproduce this, and the requested feedback was not provided. Please feel free to reopen this ticket if you had time to look into this again.

Issue History

Date Modified Username Field Change
2019-08-15 19:06 dinu New Issue
2019-08-20 09:07 derick Assigned To => derick
2019-08-20 09:07 derick Status new => feedback
2019-08-20 09:07 derick Note Added: 0005118
2019-09-06 11:27 derick Status feedback => resolved
2019-09-06 11:27 derick Resolution open => unable to reproduce
2019-09-06 11:27 derick Note Added: 0005136