View Issue Details

IDProjectCategoryView StatusLast Update
0000186XdebugFeature/Change requestpublic2006-05-31 21:38
ReporterweigonAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000186: Parse Errors are not displayed when xdebug is loaded
Descriptionwhen xdebug is loaded parse errors are not displayed, unloading xdebug displays them again.

Tested with PHP 5.1.4 and xdebug 2.0.0b5
Additional Information$ cat foo.php
<?php } ?>
 
$ php -l foo.php
PHP Parse error: syntax error, unexpected '}' in foo.php on line 1
Errors parsing foo.php
 
with xdebug loaded:
$ php -l foo.php
Errors parsing foo.php
TagsNo tags attached.
Operating SystemLinux
PHP Version5.1-dev

Activities

derick

2006-05-31 21:38

administrator   ~0000417

Works fine already:

derick@kossu:/tmp$ cat /tmp/bug000186.php
<?php } ?>
derick@kossu:/tmp$ php -l bug000186.php

Parse error: syntax error, unexpected '}' in bug000186.php on line 1
Errors parsing bug000186.php

derick@kossu:/tmp$ php -v
PHP 5.1.3RC4-dev (cli) (built: Apr 22 2006 11:58:50) (DEBUG)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
    with Xdebug v2.0.0rc1-dev, Copyright (c) 2002, 2003, 2004, 2005, 2006, by Derick Rethans

Issue History

Date Modified Username Field Change
2006-05-31 20:44 weigon New Issue
2006-05-31 21:38 derick Status new => resolved
2006-05-31 21:38 derick Resolution open => unable to reproduce
2006-05-31 21:38 derick Assigned To => derick
2006-05-31 21:38 derick Note Added: 0000417