View Issue Details

IDProjectCategoryView StatusLast Update
0001867XdebugDocumentationpublic2020-11-03 16:39
Reporterglen Assigned Toderick  
PriorityhighSeverityminorReproducibilityN/A
Status resolvedResolutionno change required 
Product Version3.0.0beta1 
Summary0001867: debugclient is gone from 3.0.0beta1
Descriptiondebugclient subdir is missing, but not whatsoever mentioned in any changelogs what happened to it.

as a distribution packager, this is important to know what it happened, is it available under different name? under different project? dropped?

so far checked:
- https://bugs.xdebug.org/view_all_bug_page.php (sorry no permalink for search result is available)
- https://xdebug.org/updates#x_3_0_0beta1
- https://3.xdebug.org/announcements/2020-10-14
TagsNo tags attached.
Operating System
PHP Version7.4.0-7.4.4

Activities

glen

2020-10-24 15:41

reporter   ~0005479

found this PR:
- https://github.com/xdebug/xdebug/pull/553

however, it should have better visibility, mentioned in release notes, changelogs.
and perhaps info when the source be made available.

glen

2020-10-24 15:50

reporter   ~0005480

foun documentation of debug client:
- https://3.xdebug.org/docs/dbgpClient

so it's definitely not superseded or outdated.

derick

2020-10-27 13:27

administrator   ~0005481

The debugclient that was part of the Xdebug source package has indeed been discontinued. Because it wasn't part of Xdebug itself, it did not make it into the changelog.

The dbgpClient that you refer to is a totally new client, written in Go, but I haven't made the source publicly available yet.

Issue History

Date Modified Username Field Change
2020-10-24 15:38 glen New Issue
2020-10-24 15:41 glen Note Added: 0005479
2020-10-24 15:50 glen Note Added: 0005480
2020-10-27 13:27 derick Note Added: 0005481
2020-11-03 16:39 derick Assigned To => derick
2020-11-03 16:39 derick Status new => resolved
2020-11-03 16:39 derick Resolution open => no change required