View Issue Details

IDProjectCategoryView StatusLast Update
0001955XdebugDocumentationpublic2021-08-06 17:28
Reporterhgs Assigned Toderick  
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version3.0.0 
Summary0001955: Instructions using https://xdebug.org/wizard displays wrong link
DescriptionThe instructions generated when analysing the output of phpinfo()
inlcudes a non existing target "Download php_xdebug-3.0.3-8.0-vs16-x86_64.dll"
in this case, http://xdebug.org/files/php_xdebug-3.0.3-8.0-vs16-x86_64.dll.

At https://xdebug.org there is no directory 'files'
Steps To ReproduceTry the wizzard.
Additional InformationIn addition to the non existing directory 'files' there is no hint on https://xdebug.org
from where to download the library.

With some guess work I ended up using https://xdebug.org/download and found there
PHP 8.0 VS16 TS (64 bit) as a link to php_xdebug-3.0.3-8.0-vs16-x86_64.dll, mentioned above.

It would be very kind to rework the output of the wizard and/or add some more links
to the home page https://xdebug.org
TagsNo tags attached.
Operating System
PHP Version8.0.0-8.0.4

Activities

derick

2021-03-17 08:14

administrator   ~0005714

You are not allowed to list the `/files` directory, but the file http://xdebug.org/files/php_xdebug-3.0.3-8.0-vs16-x86_64.dll can be downloaded directly. This is as expected.

hgs

2021-03-17 08:35

reporter   ~0005719

When trying to load the dll from the wizard page Chrome says:


Mixed Content: The site at 'https://xdebug.org/' was loaded over a secure connection, but the file at 'https://xdebug.org/files/php_xdebug-3.0.3-8.0-vs16-x86_64.dll' was redirected through an insecure connection. This file should be served over HTTPS. This download has been blocked. See https://blog.chromium.org/2020/02/protecting-users-from-insecure.html for more details.

hgs

2021-03-17 08:59

reporter   ~0005734

Please have a look at my note.
It won't download in Chrome 89

derick

2021-08-06 17:28

administrator   ~0005953

I can't reproduce this. It downloads fine for me in all browsers, including Chrome.

Issue History

Date Modified Username Field Change
2021-03-16 17:00 hgs New Issue
2021-03-17 08:14 derick Assigned To => derick
2021-03-17 08:14 derick Status new => resolved
2021-03-17 08:14 derick Resolution open => no change required
2021-03-17 08:14 derick Note Added: 0005714
2021-03-17 08:35 hgs Note Added: 0005719
2021-03-17 08:59 hgs Status resolved => new
2021-03-17 08:59 hgs Resolution no change required => reopened
2021-03-17 08:59 hgs Note Added: 0005734
2021-08-06 17:28 derick Status new => resolved
2021-08-06 17:28 derick Resolution reopened => unable to reproduce
2021-08-06 17:28 derick Note Added: 0005953