View Issue Details

IDProjectCategoryView StatusLast Update
0001990XdebugStep Debuggingpublic2021-08-18 12:25
Reportermbelogubov Assigned Toderick  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformLinuxOSKubuntuOS Version20.10
Product Version3.0.4 
Summary0001990: Step debugging causes many error logging
DescriptionI use VS Code and felixfbecker.php-debug extension.
I run project that uses Smarty template engine.
When I enable step debugging (no breakpoints) xdebug outputs lots of notices like this:

<?xml version="1.0" encoding="iso-8859-1"?><notify xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" name="error"><xdebug:message filename="file:///***.tpl.php" lineno="240" type="Notice"><![CDATA[Undefined index: attrs]]></xdebug:message></notify>

These messages continue appearing even when php script is finished. If I enable xdebug profiling, I can see that profiling output file stops growing, so it means php script finished its work. But xdebug still generates output notices and server can't send response to browser until this process end.

Enabling/disabling xdebug logging or profiling doesn't change anything.

This issue doesn't appear on xdebug v2.x.x, but appears on 3.x.x.

xdebug config:

xdebug.client_host = "127.0.0.1"
xdebug.client_port = 9000
xdebug.idekey="vscode"

xdebug.log_level = 0
xdebug.mode="debug"

xdebug.start_with_request="trigger"
xdebug.trigger_value=""

xdebug.force_error_reporting = 0
xdebug.force_display_errors = 0
TagsNo tags attached.
Operating System
PHP Version8.0.0-8.0.4

Relationships

has duplicate 0001991 closedderick Step debugging causes many error logging 

Activities

derick

2021-06-30 11:37

administrator   ~0005920

Where does Xdebug output this?

This is part of the communication between Xdebug and VS Code, and should not show up on standard output.

derick

2021-08-07 10:08

administrator   ~0005967

Can you please produce the requested information?

derick

2021-08-18 12:25

administrator   ~0005988

Can't reproduce, and the requested information wasn't provided. Please open a new issue if this is still a problem, but then with that additional information.

Issue History

Date Modified Username Field Change
2021-06-30 10:15 mbelogubov New Issue
2021-06-30 10:18 mbelogubov Issue cloned: 0001991
2021-06-30 11:22 derick Relationship added has duplicate 0001991
2021-06-30 11:37 derick Assigned To => derick
2021-06-30 11:37 derick Status new => feedback
2021-06-30 11:37 derick Note Added: 0005920
2021-08-07 10:08 derick Note Added: 0005967
2021-08-18 12:25 derick Status feedback => closed
2021-08-18 12:25 derick Resolution open => unable to reproduce
2021-08-18 12:25 derick Note Added: 0005988