View Issue Details

IDProjectCategoryView StatusLast Update
0002012XdebugUncategorizedpublic2021-09-06 14:22
Reporterjeremydenoun Assigned Toderick  
PrioritynormalSeveritymajorReproducibilityN/A
Status resolvedResolutionno change required 
Product Version3.0.4 
Summary0002012: Helpers : Xdebug version & xdebug_info
DescriptionHi,

I'm working with xdebug 2 and now with xdebug 3, and I have an issue with your actual information exposition.

You don't have any helper that expose actual version outside xdebug_info()
(actual behavior xdebug_info only print html and OMHO this isn't a best practice to ob_start + ob_end and parse html to each request...)

on future xdebug3.1-dev you have change xdebug_info function signature to support "categories" that can help us to fetch some usefull informations, but will be potentially error source if we implement code with xdebug_info('mode') wait array and have xdebug page because we don't have right version (by example last debian 11 provide 3.0.4 and this shouldn't be update until next version and this is a LTS version -- 5 years)

I think you should consider add xdebug_version function and maybe xdebug_configuration( string $category = null ) before release 3.1, I think this will be easier to handle change and version

Thanks
TagsNo tags attached.
Operating SystemDebian 11
PHP Version8.0.0-8.0.4

Activities

derick

2021-08-27 18:22

administrator   ~0005996

Can't you use phpversion('xdebug') ; to get the extension's version?

I don't find it necessary to add an extra function for this, and hence I also don't think I need an extra new function to get the extra info such as modes or whether compression is available.

jeremydenoun

2021-09-01 16:56

reporter   ~0005998

Thanks, yes I can use phpversion('xdebug') and no need to create any extra function for this.

About configuration, you should consider follow php behavior (apply to himself) :
- phpinfo return html with param to select specific part (but always print html)
- ini_get/get_cfg_var fetch specific options (return string or array with details)

Otherwise you impose to all your users to check, compare and analysis a function return that can print&die regarding version.

I let you decide what's the best, thank for your answer

Issue History

Date Modified Username Field Change
2021-08-27 12:31 jeremydenoun New Issue
2021-08-27 18:22 derick Assigned To => derick
2021-08-27 18:22 derick Status new => feedback
2021-08-27 18:22 derick Note Added: 0005996
2021-09-01 16:56 jeremydenoun Note Added: 0005998
2021-09-01 16:56 jeremydenoun Status feedback => assigned
2021-09-06 14:22 derick Status assigned => resolved
2021-09-06 14:22 derick Resolution open => no change required