View Issue Details

IDProjectCategoryView StatusLast Update
0002016XdebugUncategorizedpublic2021-10-15 13:19
ReporterJeremyDunn Assigned Toderick  
PriorityhighSeverityblockReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindowsOS VersionWin10 Pro 21H1
Product Version3.1.0beta2 
Target Version3.1devFixed in Version3.1.1 
Summary0002016: apache gives no output with xdebug 3.1.0b2 installed
Descriptionreplaced 3.0.4 which works fine, with 3.1b2
running apache 2.4.47 x64 built by apachelounge

open a simple PHP page that has only phpinfo();
with xdebug 3.1.0b2 installed, page gives *NO OUTPUT*. Works fine with 3.0.4
Steps To Reproduce1. download 3.1.0b2 8.0 TS x64
2. install to php/ext folder
3. change php.ini extension name
4. restart apache - log shows it starts ok
5. open a simple script which contains only phpinfo();

previously shows PHP 8.0.8 with xdebug 3.0.4
now shows *nothing* - no output whatsoever

6. from command line : php -r "phpinfo();" WORKS and shows xdebug 3.1.0b2 is loaded.

Looks like the problem may be in apache/xdebug interaction
I'm on apache 2.4.47 build by apachelounge - works fine for xdebug 3.0.4

upgraded to httpd 2.4.48 with the SAME behavior: 3.0.4 works fine; 3.1.0b2 produces no output
Additional Informationthere is nothing unusual in apache error log; nothing in xdebug.log; nothing in PHP error log

C:\Users\Jeremy>php -v
PHP 8.0.8 (cli) (built: Jun 29 2021 16:02:52) ( ZTS Visual C++ 2019 x64 )
Copyright (c) The PHP Group
Zend Engine v4.0.8, Copyright (c) Zend Technologies
    with Zend OPcache v8.0.8, Copyright (c), by Zend Technologies
    with Xdebug v3.1.0beta2, Copyright (c) 2002-2021, by Derick Rethans

(NOTE: PHP version selector in Mantis only goes to 8.0.4 - I'm running 8.0.8)

PHP.ini:
======
;zend_extension=php_xdebug-3.0.4-8.0-vs16-x86_64.dll
zend_extension=php_xdebug-3.1.0beta2-8.0-vs16-x86_64.dll

[xdebug]
xdebug.log="<PATH-REMOVED>\xdebug.log"
xdebug.mode=debug
xdebug.client_host=localhost
xdebug.client_port=9000
xdebug.idekey="netbeans-xdebug"
xdebug.output_dir="<PATH-REMOVED>"
xdebug.var_display_max_depth=20
xdebug.var_display_max_children=-1
xdebug.var_display_max_data=-1
TagsNo tags attached.
Operating SystemWindows 10 Pro 21H1
PHP Version8.0.5-8.0.9

Activities

derick

2021-09-16 08:48

administrator   ~0006007

I'm not quite sure how to dive into this. Is there Anything in your PHP or Apache error logs perhaps? A note of a crash, or some other error?

JeremyDunn

2021-09-16 09:42

reporter   ~0006011

xdebug log after restarting Apache with 3.1.0b2 installed:

[23900] Log opened at 2021-09-16 09:28:00.704547
[23900] [Config] INFO: Trigger value for 'XDEBUG_TRIGGER' not found, falling back to 'XDEBUG_SESSION'
[23900] [Config] INFO: Trigger value for 'XDEBUG_SESSION' not found, so not activating

has something changed in the config required between 3.0.4 and 3.1.0b2 ? all my php.ini entries related to xdebug are in the original problem report
=====
there is nothing in the apache error log; but it looks like xdebug / apache httpd crashed. this is from the Windows Event log:

Faulting application name: httpd.exe, version: 2.4.48.0, time stamp: 0x612616a0
Faulting module name: php_xdebug-3.1.0beta2-8.0-vs16-x86_64.dll, version: 3.1.0.1, time stamp: 0x6137725c
Exception code: 0xc0000005
Fault offset: 0x000000000000c7f0
Faulting process id: 0x1808
Faulting application start time: 0x01d7aadd0c7915cd
Faulting application path: C:\Program Files\Apache2.4.48\bin\httpd.exe
Faulting module path: C:\Program Files\php8\ext\php_xdebug-3.1.0beta2-8.0-vs16-x86_64.dll
Report Id: 8d1802bc-1629-4e42-b042-900328c67ae7
Faulting package full name:
Faulting package-relative application ID:

=====
I installed windows procdump64 and it generated TWO .dmp files when apache crashed, both of which are 4mb. Are these of any value? And/or would it be helpful for me to follow the instructions here (https://bugs.php.net/bugs-generating-backtrace-win32.php) to run DebugDiag? I have no experience with this but am willing to try. Please advise.

JeremyDunn

2021-09-16 11:32

reporter   ~0006018

attached is the DebugDiag analysis for the crash dumps mentioned in previous comment

one note: I'm running PHP 8.0.8 but downloaded debug-pack 8.0.10 because it was handy. Please let me know if this causes a problem and I'll do it again...

JeremyDunn

2021-09-20 17:53

reporter   ~0006020

Hi Derick - was the information provided on 16-Sept sufficient for you to debug? Anything else I can offer to help out ?

derick

2021-09-22 10:06

administrator   ~0006026

I've just had another look, and I can't really tell much from these reports. There seems to be an exception thrown from an internal method... which I don't think can actually happen there.

I also can't attempt to reproduce this locally, as I don't have Windows.

Do you perhaps have opcache loaded? And do you have that with opcache.protect_memory perhaps?

derick

2021-09-22 10:22

administrator   ~0006028

Last edited: 2021-09-22 10:30

As an additional note, yes, it would be useful to make a backtrace as in https://bugs.php.net/bugs-generating-backtrace-win32.php — you can download the debug symbol version of the extension at https://windows.php.net/downloads/pecl/releases/xdebug/3.1.0beta2/php_xdebug-3.1.0beta2-8.0-ts-vs16-x64.zip (and also extract the .pcb file).

And you also need to match the debug symbols with the right version of PHP itself, you can't mix 8.0.8 and 8.0.10. You can find them at:
- https://windows.php.net/downloads/releases/archives/php-8.0.10-Win32-vs16-x64.zip
- https://windows.php.net/downloads/releases/archives/php-devel-pack-8.0.10-Win32-vs16-x64.zip

JeremyDunn

2021-09-22 13:10

reporter   ~0006029

Hi Derick - thanks for taking another look.

I just installed PHP 8.0.11 and verified that apache still crashes with xdebug 3.1.0b2 loaded; but works ok with xdebug 3.0.4

Installed PHP 8.0.11 symbol pack and also xdebug 3.1.0b2 symbol pack (to the ../debug/ subdirectory of my php install)

then ran Windows DebugDiag 3.2 on the .dmp file. It's definitely identifying the crash in xdebug. See top of the attached .mht file, and analysis of threads 17 and 175

I don't know why it's not finding the xdebug symbols. They're in the same directory as the PHP symbols, and that directory is in the DebugDiag symbol-path.

Also to answer your question, Yes I have php_opache loaded, but No I am not using opcache.protect_memory. Also I have opcache.jit = Off - it seems to not work in php8 on windows.

my xdebug settings are the same as in the original problem report.

JeremyDunn

2021-09-22 13:10

reporter   ~0006030

here's the output of DebugDiag

derick

2021-09-22 14:52

administrator   ~0006032

Hi, thanks for doing this. Without the symbols present it seems unlikely that I can figure out what the problem is. I would perhaps suggest to put the .pdb file in the same directory as the .dll? Would you mind trying that?

cheers,
Derick

JeremyDunn

2021-09-22 16:55

reporter   ~0006033

putting the symbol file in the same path as the .dll had no effect.

changing the load-order of the symbol-paths might have helped.....but it *still* says it cannot find the xdebug symbols....no idea why not since they're clearly present in the same directory (php_xdebug.pdb)

Please find attached an updated analysis of the same dump. The relevant info appears to be on thread 28, as follows:


Thread 28 - System ID 12712
Entry point ucrtbase!thread_start
Create time 9/22/2021 12:00:34 PM
Time spent in user mode 0 Days 00:00:00.000
Time spent in kernel mode 0 Days 00:00:00.000

This thread is not fully resolved and may or may not be a problem. Further analysis of these threads may be required.

Instruction Address Source
[0x7ffd891ed8c4] ntdll!NtWaitForMultipleObjects+14
[0x7ffd868bcb70] KERNELBASE!WaitForMultipleObjectsEx+f0
[0x7ffd868bca6e] KERNELBASE!WaitForMultipleObjects+e
[0x7ffd882e092a] kernel32!WerpReportFaultInternal+58a
[0x7ffd882e0366] kernel32!WerpReportFault+be
[0x7ffd8697c539] KERNELBASE!UnhandledExceptionFilter+3d9
[0x7ffd891f51b0] ntdll!RtlUserThreadStart$filt$0+a2
[0x7ffd891dc766] ntdll!_C_specific_handler+96
[0x7ffd891f20cf] ntdll!RtlpExecuteHandlerForException+f
[0x7ffd891a1454] ntdll!RtlDispatchException+244
[0x7ffd891f0bfe] ntdll!KiUserExceptionDispatch+2e
[0x7ffd5758c7f0] php_xdebug_3_1_0beta2_8_0_vs16_x86_64!xdebug_init_oparray+a5a0
[0x7ffd57588e88] php_xdebug_3_1_0beta2_8_0_vs16_x86_64!xdebug_init_oparray+6c38
[0x7ffd537e1b71] php8ts!ZEND_USER_OPCODE_SPEC_HANDLER+21 [D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend_vm_execute.h @ 2985] D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend_vm_execute.h @ 2985
[0x7ffd5330e4cf] php8ts!execute_ex+4f [D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend_vm_execute.h @ 53959 + f] D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend_vm_execute.h @ 53959 + f
[0x7ffd57584608] php_xdebug_3_1_0beta2_8_0_vs16_x86_64!xdebug_init_oparray+23b8
[0x7ffd532fe68f] php8ts!zend_execute+1af [D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend_vm_execute.h @ 58501] D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend_vm_execute.h @ 58501
[0x7ffd532fe02c] php8ts!zend_execute_scripts+dc [D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend.c @ 1681] D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend.c @ 1681
[0x7ffd532fde5e] php8ts!php_execute_script+1ce [D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\main\main.c @ 2524 + 1b] D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\main\main.c @ 2524 + 1b
[0x7ffd58293b1e] php8apache2_4!php_handler+55e [D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\sapi\apache2handler\sapi_apache2.c @ 705] D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\sapi\apache2handler\sapi_apache2.c @ 705
[0x7ffd5728f175] libhttpd!ap_run_handler+35
[0x7ffd5728dd5f] libhttpd!ap_invoke_handler+10f
[0x7ffd5728aa1a] libhttpd!ap_internal_redirect_handler+29a
[0x7ffd5728aa9f] libhttpd!ap_process_request+f
[0x7ffd57d7883f] mod_http2+1883f
[0x7ffd57291835] libhttpd!ap_run_process_connection+35
[0x7ffd57d7850b] mod_http2+1850b
[0x7ffd57d7c48e] mod_http2+1c48e
[0x7ffd86bc1bb2] ucrtbase!thread_start<unsigned int (__cdecl*)(void *),1>+42
[0x7ffd88287034] kernel32!BaseThreadInitThunk+14
[0x7ffd891a2651] ntdll!RtlUserThreadStart+21

JeremyDunn

2021-09-22 16:55

reporter   ~0006034

derick

2021-09-23 13:05

administrator   ~0006037

Did you use the php_xdebug.dll files **and** the PDB file from this package (https://windows.php.net/downloads/pecl/releases/xdebug/3.1.0beta2/php_xdebug-3.1.0beta2-8.0-ts-vs16-x64.zip)? If you picked a different DLL, it might not work. I'm running out of ideas though, but having working symbols is going to be key :-/

JeremyDunn

2021-09-23 15:59

reporter   ~0006042

> Did you use the php_xdebug.dll files **and** the PDB file from this package (https://windows.php.net/downloads/pecl/releases/xdebug/3.1.0beta2/php_xdebug-3.1.0beta2-8.0-ts-vs16-x64.zip)? If you picked a different DLL, it might not work. I'm running out of ideas though, but having working symbols is going to be key :-/

well, I *thought* I had, but apparently not. Sorry for the confusion.

Just tried again:
 * downloaded the zip file
 * extracted .dll and installed to /ext/ folder
 * updated php.ini
 * restarted apache
 * opened a page with just phpinfo(); apache crashed
 * extracted .pdb and installed to /debug/ folder with other PHP symbol files
 * ran DebugDiag using /debug/ path
 * got an .mht file that does NOT claim that the symbols are missing - apparently it works now.

error is in thread 99 :
==================
Thread 99 - System ID 3784
Entry point ucrtbase!thread_start
Create time 9/23/2021 11:53:54 AM
Time spent in user mode 0 Days 00:00:00.000
Time spent in kernel mode 0 Days 00:00:00.015


This thread is not fully resolved and may or may not be a problem. Further analysis of these threads may be required.

Instruction Address Source
[0x7fff910cd8c4] ntdll!NtWaitForMultipleObjects+14
[0x7fff8e90cb70] KERNELBASE!WaitForMultipleObjectsEx+f0
[0x7fff8e90ca6e] KERNELBASE!WaitForMultipleObjects+e
[0x7fff8fb6092a] kernel32!WerpReportFaultInternal+58a
[0x7fff8fb60366] kernel32!WerpReportFault+be
[0x7fff8e9cc539] KERNELBASE!UnhandledExceptionFilter+3d9
[0x7fff910d51b0] ntdll!RtlUserThreadStart$filt$0+a2
[0x7fff910bc766] ntdll!_C_specific_handler+96
[0x7fff910d20cf] ntdll!RtlpExecuteHandlerForException+f
[0x7fff91081454] ntdll!RtlDispatchException+244
[0x7fff910d0bfe] ntdll!KiUserExceptionDispatch+2e
[0x7fff1c2bc7f0] php_xdebug_3_1_0beta2_8_0_vs16_x86_64!xdebug_set_in_ex [C:\php-snap-build\php-src\php80\x64\php-src\ext\xdebug\src\lib\set.c @ 62] C:\php-snap-build\php-src\php80\x64\php-src\ext\xdebug\src\lib\set.c @ 62
[0x7fff1c2b8e88] php_xdebug_3_1_0beta2_8_0_vs16_x86_64!xdebug_opcode_multi_handler+88 [C:\php-snap-build\php-src\php80\x64\php-src\ext\xdebug\src\lib\lib.c @ 628 + 2f] C:\php-snap-build\php-src\php80\x64\php-src\ext\xdebug\src\lib\lib.c @ 628 + 2f
[0x7fff5a471b71] php8ts!ZEND_USER_OPCODE_SPEC_HANDLER+21 [D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend_vm_execute.h @ 2985] D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend_vm_execute.h @ 2985
[0x7fff59f9e4cf] php8ts!execute_ex+4f [D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend_vm_execute.h @ 53959 + f] D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend_vm_execute.h @ 53959 + f
[0x7fff1c2b4608] php_xdebug_3_1_0beta2_8_0_vs16_x86_64!xdebug_execute_ex+5a8 [C:\php-snap-build\php-src\php80\x64\php-src\ext\xdebug\src\base\base.c @ 783] C:\php-snap-build\php-src\php80\x64\php-src\ext\xdebug\src\base\base.c @ 783
[0x7fff59f8e68f] php8ts!zend_execute+1af [D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend_vm_execute.h @ 58501] D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend_vm_execute.h @ 58501
[0x7fff59f8e02c] php8ts!zend_execute_scripts+dc [D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend.c @ 1681] D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\Zend\zend.c @ 1681
[0x7fff59f8de5e] php8ts!php_execute_script+1ce [D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\main\main.c @ 2524 + 1b] D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\main\main.c @ 2524 + 1b
[0x7fff5aca3b1e] php8apache2_4!php_handler+55e [D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\sapi\apache2handler\sapi_apache2.c @ 705] D:\a\php-ftw\php-ftw\php\vs16\x64\php-8.0.11\sapi\apache2handler\sapi_apache2.c @ 705
[0x7fff75e4f175] libhttpd!ap_run_handler+35
[0x7fff75e4dd5f] libhttpd!ap_invoke_handler+10f
[0x7fff75e4aa1a] libhttpd!ap_internal_redirect_handler+29a
[0x7fff75e4aa9f] libhttpd!ap_process_request+f
[0x7fff5b62883f] mod_http2+1883f
[0x7fff75e51835] libhttpd!ap_run_process_connection+35
[0x7fff5b62850b] mod_http2+1850b
[0x7fff5b62c48e] mod_http2+1c48e
[0x7fff8ebb1bb2] ucrtbase!thread_start<unsigned int (__cdecl*)(void *),1>+42
[0x7fff8fb07034] kernel32!BaseThreadInitThunk+14
[0x7fff91082651] ntdll!RtlUserThreadStart+21
===============
does that help ??

entire .mht file will be attached next...

JeremyDunn

2021-09-23 15:59

reporter   ~0006043

JeremyDunn

2021-09-28 11:07

reporter   ~0006053

Hi Derick - did the stack-trace reported on 23-Sept provide sufficient information to debug the problem ?

derick

2021-09-28 13:48

administrator   ~0006054

The trace is a lot more useful, but I don't quite know what the problem is. Thanks for making it!

JeremyDunn

2021-10-04 11:51

reporter   ~0006073

I see that 3.1 was released; unfortunately this bug still exists in the production version. Is there any path forward? Any way I can help ??

derick

2021-10-05 10:35

administrator   ~0006078

As I've said before. I don't know what the issue is, and I can't reproduce it — mostly because I don't have Windows, I suppose. However, the PHP Windows maintainer/guru Christopher, can also not reproduce this issue.

The thing that would help me most is being able to reproduce this on a Linux platform, where I have much better tools available for debugging.

JeremyDunn

2021-10-05 12:29

reporter   ~0006080

more information:

1. tried with latest apache httpd 2.4.50 (released yesterday 2021-10-05) from apachelounge.com. problem is the same

2. disabled ALL my PHP extensions except xdebug. problem is the same

3. in xdebug log file, every time apache starts I see this. Is it significant?

[15608] Log opened at 2021-10-05 11:40:10.337882
[15608] [Config] INFO: Trigger value for 'XDEBUG_TRIGGER' not found, falling back to 'XDEBUG_SESSION'
[15608] [Config] INFO: Trigger value for 'XDEBUG_SESSION' not found, so not activating

again, my xdebug config settings are:

xdebug.output_dir="c:\temp"
xdebug.log="C:\temp\xdebug.log"
xdebug.log_level=10
xdebug.mode=debug
xdebug.client_host=localhost
xdebug.client_port=9000
xdebug.idekey="netbeans-xdebug"

xdebug.var_display_max_depth=20
xdebug.var_display_max_children=-1
xdebug.var_display_max_data=-1

I tried removing the last three settings - problem persists

4. I just noticed xdebug_info() and tried it for the first time. it WORKS. Apache does not crash. Output from xdebug_info() will be attached.

5. The php file I was executing contained a security provision, like this:

$matchCount = preg_match('/^(127|10|192\.168)\./', $_SERVER['REMOTE_ADDR']);
if (1 === $matchCount) {
    phpinfo();
}

removing ALL the code except phpinfo(); it WORKS
with ANY other code - it crashes

example:
$x=1;
phpinfo(); // crashes

//$x=1;
phpinfo(); // works

phpinfo();
$x=1; // crashes


6. tried with VERY minimal php.ini (see attached). removed everything except xdebug
behavior is the same. crashes with any line of code except phpinfo();

JeremyDunn

2021-10-05 12:30

reporter   ~0006081

attached files:

1. xdebug.3.0.htm = output of xdebug_info()

2. php.ini = very minimal php config
Xdebug 3.1.0.htm (17,140 bytes)   
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"><head>
<meta http-equiv="content-type" content="text/html; charset=UTF-8">
<style type="text/css">
body {background-color: #fff; color: #222; font-family: sans-serif;}
pre {margin: 0; font-family: monospace;}
a:link, a:hover, a:visited {color: black; text-decoration: underline;}
table {border-collapse: separate; border: 1px solid #666; width: 934px; box-shadow: 1px 2px 3px #ccc; border-bottom: none; border-right: none; border-spacing: 0;}
.center {text-align: center;}
.center table {margin: 1em auto; text-align: left;}
.center th {text-align: center !important;}
td, th {border: 1px solid #666; font-size: 75%; vertical-align: baseline; padding: 4px 5px; border-left: none; border-top: none;}
th {top: 0; background: inherit; position: sticky;}
h1 {font-size: 150%;}
h2 {font-size: 125%;}
.p {text-align: left;}
.e {background-color: #e5f5d5; width: 300px; font-weight: bold;}
.h {background-color: #bbde94; font-weight: bold;}
.v {background-color: #ddd; max-width: 300px; overflow-x: auto; word-wrap: break-word;}
.i {background-color: #ddd; text-align: center; font-size: 1em; font-family: serif; width: 1em;}
.v i {color: #999;}
.d {background-color: #ddd; width: 1em; text-align: center;}
.l {background-color: #bbde94;}
img {float: right; border: 0;}
hr {width: 934px; background-color: #ccc; border: 0; height: 1px;}
</style>
<title>Xdebug 3.1.0</title><meta name="ROBOTS" content="NOINDEX,NOFOLLOW,NOARCHIVE"></head>
<body cz-shortcut-listen="true"><div class="center">
<table>
<tbody><tr><td colspan="2" class="l"><svg xmlns="http://www.w3.org/2000/svg" width="176" height="91" viewBox="0 0 351 181"><title>Xdebug</title><g fill="none" fill-rule="evenodd" stroke="#FFF"><g transform="translate(5 5)"><path fill="#317E1E" fill-rule="nonzero" stroke-width="5" d="M127.9 85.5l68.2 70.7.4 17.3h-38.6l-60.8-59.7-60 59.7h-39v-17.6l69.7-69.8-69.6-71.2V-2.5h38.7l60.2 60 61-60h38.3v16l-68.5 72z"></path><circle cx="75.9" cy="74.6" r="3.5" stroke-opacity=".8" stroke-width="4"></circle><circle cx="105.1" cy="85" r="3.5" stroke-opacity=".8" stroke-width="4"></circle><circle cx="158.4" cy="15" r="3.5" stroke-opacity=".8" stroke-width="4"></circle><circle cx="50.9" cy="140" r="3.5" stroke-opacity=".8" stroke-width="4"></circle><circle cx="180.4" cy="158.5" r="3.5" stroke-opacity=".8" stroke-width="4"></circle><path stroke-linecap="square" stroke-linejoin="round" stroke-width="4" d="M32.6 158.2L42 149M104.3 69.1l49.4-49.4"></path><path stroke-linejoin="round" stroke-width="4" d="M102.3 82.7L30.3 10H11.2M167.4 10H183M11.2 160.7l79.2-78"></path><path stroke-linejoin="round" stroke-opacity=".7" stroke-width="4" d="M116.3 74.6L181 10"></path><path stroke-linejoin="round" stroke-width="4" d="M20.7 19.7l52.7 52.6"></path><path stroke-linejoin="round" stroke-opacity=".7" stroke-width="4" d="M116.3 96.7l32 32"></path><path stroke-linejoin="round" stroke-width="4" d="M155.2 133.6l22.1 22M53.6 137.5L97 94.9l67.1 66.6h4.9"></path></g><g fill="#000" fill-rule="nonzero" stroke-width="4"><path d="M158.3 107.7V72.9c0-.5 0-.5-.8-.5-.7 0-.7 0-.7.6v34.7c0 .6 0 .5.7.5.8 0 .7 0 .7-.5zm3.9 11.2a22.5 22.5 0 0 1-20-.7c-3.4-2-5.2-4.8-5.2-8.4V69.6c0-3 1.5-5.6 4.3-7.4a17 17 0 0 1 9.2-2.4c3 0 5.6.3 7.7 1V47H178v73h-15l-.8-1.1zM200.9 84V73.2c0-.8 0-.8-.8-.8s-.8 0-.8.8V84h1.6zm-1.6 12.5v11c0 .7 0 .7.8.7.7 0 .8 0 .8-.8V97.2h19.8v10.4c0 8.9-7.3 13.2-20.7 13.2-13.3 0-20.5-4.5-20.5-13.7V73.6c0-9.2 7.2-13.8 20.5-13.8 13.4 0 20.7 4.4 20.7 13.4v23.3h-21.4zM243.3 107.7V73c0-.6 0-.6-.7-.6-.8 0-.8 0-.8.5v34.8c0 .6 0 .5.8.5.7 0 .7 0 .7-.5zm-5.4 11.1l-.9 1.3h-15V47h19.8v13.8c2.1-.7 4.7-1 7.9-1 3.1 0 6.1.8 8.8 2.3 3 1.6 4.6 4.2 4.6 7.5v40.2c0 3.6-1.8 6.4-5.3 8.4a22.5 22.5 0 0 1-19.9.6zM285.8 119.7c-2.1.8-4.7 1.1-7.8 1.1a17 17 0 0 1-9.1-2.4c-2.8-1.7-4.4-4.2-4.4-7.2v-51h19.8v47.5c0 .6 0 .5.8.5.7 0 .7 0 .7-.4V60h19.8v60h-19.8v-.4zM328.3 108.3V73c0-.6 0-.6-.7-.6-.8 0-.8 0-.8.6V108c0 .6 0 .6.8.6.7 0 .7 0 .7-.4zm-.9 11.8c-2 .5-4.2.7-6.9.7a17 17 0 0 1-9.1-2.4c-2.9-1.7-4.4-4.2-4.4-7.2V71c0-7.4 5.2-11.2 14.6-11.2 2.3 0 5 .7 8.3 2l1.7-1.7H348v57.3c0 4.4-1 9.5-2.8 12-2.1 3.2-7.7 4.5-17 4.5h-18.4v-12h14.9c1.1 0 2-.7 2.7-1.8z"></path></g></g></svg></td></tr>
<tr><td class="e">Version </td><td class="v">3.1.0 </td></tr>
<tr><td colspan="2" style="background-color: white; text-align: center"><a style="color: #317E1E; background-color: transparent; font-weight: bold; text-decoration: underline" href="https://xdebug.org/support">Support Xdebug on Patreon, GitHub, or as a business</a></td></tr>
</tbody></table>
<table>
<tbody><tr class="h"><th colspan="3">Enabled Features<br>(through 'xdebug.mode' setting)</th></tr>
<tr class="h"><th>Feature</th><th>Enabled/Disabled</th><th>Docs</th></tr>
<tr><td class="e">Development Helpers</td><td class="v">✘ disabled</td><td class="d"><a href="https://xdebug.org/docs/develop">🖹</a></td></tr>
<tr><td class="e">Coverage</td><td class="v">✘ disabled</td><td class="d"><a href="https://xdebug.org/docs/code_coverage">🖹</a></td></tr>
<tr><td class="e">GC Stats</td><td class="v">✘ disabled</td><td class="d"><a href="https://xdebug.org/docs/garbage_collection">🖹</a></td></tr>
<tr><td class="e">Profiler</td><td class="v">✘ disabled</td><td class="d"><a href="https://xdebug.org/docs/profiler">🖹</a></td></tr>
<tr><td class="e">Step Debugger</td><td class="v">✔ enabled</td><td class="d"><a href="https://xdebug.org/docs/remote">🖹</a></td></tr>
<tr><td class="e">Tracing</td><td class="v">✘ disabled</td><td class="d"><a href="https://xdebug.org/docs/trace">🖹</a></td></tr>
</tbody></table>
<table>
<tbody><tr class="h"><th colspan="2">Optional Features</th></tr>
<tr><td class="e">Compressed File Support </td><td class="v">no </td></tr>
<tr><td class="e">Clock Source </td><td class="v">GetSystemTimePreciseAsFileTime </td></tr>
</tbody></table>
<table>
<tbody><tr class="h"><th colspan="3">Diagnostic Log</th></tr>
<tr><td class="v" colspan="3">No messages</td></tr>
</tbody></table>
<table>
<tbody><tr class="h"><th colspan="2">Step Debugging</th><th>Docs</th></tr>
<tr><td class="e">Debugger</td><td class="v">Not Active</td><td class="d"><a href="https://xdebug.org/docs/step_debug">🖹</a></td></tr>
</tbody></table>
<table>
<tbody><tr class="h"><th colspan="2">PHP</th></tr>
<tr class="h"><th colspan="2">Build Configuration</th></tr>
<tr><td class="e">Version </td><td class="v">8.0.11 </td></tr>
<tr><td class="e">Debug Build </td><td class="v">no </td></tr>
<tr><td class="e">Thread Safety </td><td class="v">enabled </td></tr>
<tr><td class="e">Thread API </td><td class="v">Windows Threads </td></tr>
<tr class="h"><th colspan="2">Settings</th></tr>
<tr><td class="e">Configuration File (php.ini) Path </td><td class="v"><i>no value</i> </td></tr>
<tr><td class="e">Loaded Configuration File </td><td class="v">C:\Program Files\php8\php.ini </td></tr>
<tr><td class="e">Scan this dir for additional .ini files </td><td class="v">(none) </td></tr>
<tr><td class="e">Additional .ini files parsed </td><td class="v">(none) </td></tr>
</tbody></table>
<table>
<tbody><tr class="h"><th>Directive</th><th>Local Value</th><th>Master Value</th><th>Docs</th></tr>
<tr><td class="e">xdebug.mode</td><td class="v">debug</td><td class="v">debug</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.mode">🖹</a></td></tr>
<tr><td class="e">xdebug.start_with_request</td><td class="v">default</td><td class="v">default</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.start_with_request">🖹</a></td></tr>
<tr><td class="e">xdebug.start_upon_error</td><td class="v">default</td><td class="v">default</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.start_upon_error">🖹</a></td></tr>
<tr><td class="e">xdebug.output_dir</td><td class="v">C:\temp</td><td class="v">C:\temp</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.output_dir">🖹</a></td></tr>
<tr><td class="e">xdebug.use_compression</td><td class="v">0</td><td class="v">0</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.use_compression">🖹</a></td></tr>
<tr><td class="e">xdebug.trigger_value</td><td class="v"><i>no value</i></td><td class="v"><i>no value</i></td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.trigger_value">🖹</a></td></tr>
<tr><td class="e">xdebug.file_link_format</td><td class="v"><i>no value</i></td><td class="v"><i>no value</i></td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.file_link_format">🖹</a></td></tr>
<tr><td class="e">xdebug.filename_format</td><td class="v"><i>no value</i></td><td class="v"><i>no value</i></td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.filename_format">🖹</a></td></tr>
<tr><td class="e">xdebug.log</td><td class="v">C:\temp\xdebug.log</td><td class="v">C:\temp\xdebug.log</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.log">🖹</a></td></tr>
<tr><td class="e">xdebug.log_level</td><td class="v">10</td><td class="v">10</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.log_level">🖹</a></td></tr>
<tr><td class="e">xdebug.var_display_max_children</td><td class="v">-1</td><td class="v">-1</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.var_display_max_children">🖹</a></td></tr>
<tr><td class="e">xdebug.var_display_max_data</td><td class="v">-1</td><td class="v">-1</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.var_display_max_data">🖹</a></td></tr>
<tr><td class="e">xdebug.var_display_max_depth</td><td class="v">20</td><td class="v">20</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.var_display_max_depth">🖹</a></td></tr>
<tr><td class="e">xdebug.max_nesting_level</td><td class="v">256</td><td class="v">256</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.max_nesting_level">🖹</a></td></tr>
<tr><td class="e">xdebug.cli_color</td><td class="v">0</td><td class="v">0</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.cli_color">🖹</a></td></tr>
<tr><td class="e">xdebug.force_display_errors</td><td class="v">Off</td><td class="v">Off</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.force_display_errors">🖹</a></td></tr>
<tr><td class="e">xdebug.force_error_reporting</td><td class="v">0</td><td class="v">0</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.force_error_reporting">🖹</a></td></tr>
<tr><td class="e">xdebug.halt_level</td><td class="v">0</td><td class="v">0</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.halt_level">🖹</a></td></tr>
<tr><td class="e">xdebug.max_stack_frames</td><td class="v">-1</td><td class="v">-1</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.max_stack_frames">🖹</a></td></tr>
<tr><td class="e">xdebug.show_error_trace</td><td class="v">Off</td><td class="v">Off</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.show_error_trace">🖹</a></td></tr>
<tr><td class="e">xdebug.show_exception_trace</td><td class="v">Off</td><td class="v">Off</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.show_exception_trace">🖹</a></td></tr>
<tr><td class="e">xdebug.show_local_vars</td><td class="v">Off</td><td class="v">Off</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.show_local_vars">🖹</a></td></tr>
<tr><td class="e">xdebug.dump.COOKIE</td><td class="v"><i>no value</i></td><td class="v"><i>no value</i></td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.dump.COOKIE">🖹</a></td></tr>
<tr><td class="e">xdebug.dump.ENV</td><td class="v"><i>no value</i></td><td class="v"><i>no value</i></td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.dump.ENV">🖹</a></td></tr>
<tr><td class="e">xdebug.dump.FILES</td><td class="v"><i>no value</i></td><td class="v"><i>no value</i></td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.dump.FILES">🖹</a></td></tr>
<tr><td class="e">xdebug.dump.GET</td><td class="v"><i>no value</i></td><td class="v"><i>no value</i></td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.dump.GET">🖹</a></td></tr>
<tr><td class="e">xdebug.dump.POST</td><td class="v"><i>no value</i></td><td class="v"><i>no value</i></td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.dump.POST">🖹</a></td></tr>
<tr><td class="e">xdebug.dump.REQUEST</td><td class="v"><i>no value</i></td><td class="v"><i>no value</i></td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.dump.REQUEST">🖹</a></td></tr>
<tr><td class="e">xdebug.dump.SERVER</td><td class="v"><i>no value</i></td><td class="v"><i>no value</i></td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.dump.SERVER">🖹</a></td></tr>
<tr><td class="e">xdebug.dump.SESSION</td><td class="v"><i>no value</i></td><td class="v"><i>no value</i></td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.dump.SESSION">🖹</a></td></tr>
<tr><td class="e">xdebug.dump_globals</td><td class="v">On</td><td class="v">On</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.dump_globals">🖹</a></td></tr>
<tr><td class="e">xdebug.dump_once</td><td class="v">On</td><td class="v">On</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.dump_once">🖹</a></td></tr>
<tr><td class="e">xdebug.dump_undefined</td><td class="v">Off</td><td class="v">Off</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.dump_undefined">🖹</a></td></tr>
<tr><td class="e">xdebug.profiler_output_name</td><td class="v">cachegrind.out.%p</td><td class="v">cachegrind.out.%p</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.profiler_output_name">🖹</a></td></tr>
<tr><td class="e">xdebug.profiler_append</td><td class="v">Off</td><td class="v">Off</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.profiler_append">🖹</a></td></tr>
<tr><td class="e">xdebug.cloud_id</td><td class="v"><i>no value</i></td><td class="v"><i>no value</i></td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.cloud_id">🖹</a></td></tr>
<tr><td class="e">xdebug.client_host</td><td class="v">localhost</td><td class="v">localhost</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.client_host">🖹</a></td></tr>
<tr><td class="e">xdebug.client_port</td><td class="v">9000</td><td class="v">9000</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.client_port">🖹</a></td></tr>
<tr><td class="e">xdebug.discover_client_host</td><td class="v">Off</td><td class="v">Off</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.discover_client_host">🖹</a></td></tr>
<tr><td class="e">xdebug.client_discovery_header</td><td class="v"><i>no value</i></td><td class="v"><i>no value</i></td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.client_discovery_header">🖹</a></td></tr>
<tr><td class="e">xdebug.idekey</td><td class="v">netbeans-xdebug</td><td class="v">netbeans-xdebug</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.idekey">🖹</a></td></tr>
<tr><td class="e">xdebug.connect_timeout_ms</td><td class="v">200</td><td class="v">200</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.connect_timeout_ms">🖹</a></td></tr>
<tr><td class="e">xdebug.scream</td><td class="v">Off</td><td class="v">Off</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.scream">🖹</a></td></tr>
<tr><td class="e">xdebug.gc_stats_output_name</td><td class="v">gcstats.%p</td><td class="v">gcstats.%p</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.gc_stats_output_name">🖹</a></td></tr>
<tr><td class="e">xdebug.trace_output_name</td><td class="v">trace.%c</td><td class="v">trace.%c</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.trace_output_name">🖹</a></td></tr>
<tr><td class="e">xdebug.trace_format</td><td class="v">0</td><td class="v">0</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.trace_format">🖹</a></td></tr>
<tr><td class="e">xdebug.trace_options</td><td class="v">0</td><td class="v">0</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.trace_options">🖹</a></td></tr>
<tr><td class="e">xdebug.collect_assignments</td><td class="v">Off</td><td class="v">Off</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.collect_assignments">🖹</a></td></tr>
<tr><td class="e">xdebug.collect_return</td><td class="v">Off</td><td class="v">Off</td><td class="d"><a href="https://xdebug.org/docs/all_settings#xdebug.collect_return">🖹</a></td></tr>
</tbody></table>
</div></body></html>
Xdebug 3.1.0.htm (17,140 bytes)   
php.ini (465 bytes)

derick

2021-10-06 14:59

administrator   ~0006084

Hi,

I think we (or rather, Christopher) found a potential fix for this. Can you try the right artefact from https://github.com/xdebug/xdebug/actions/runs/1312331369 for your set-up, and see if that fixes it?

cheers,
Derick

JeremyDunn

2021-10-06 18:02

reporter   ~0006087

Hi Derick,
Thanks to you and Christopher for the effort; but unfortunately the problem is exactly the same as before, using php_xdebug-3.1.1-dev-8.0-vs16-x86_64.dll

With only phpinfo(); in the file, it works fine; with any other line of code, apache crashes.

I'm an experienced PHP programmer but have no experience in PHP core/extension development, and no tools nor build environment. Having said this, I'm happy to try if there is some experiments I can run locally, if you provide an outline of the steps to follow.

another option is to try on another Win 10 Pro machine; or a Windows Server 2019 machine. I happen to have just built such a machine in AWS cloud; but I'm traveling today and next two days. This weekend I can try the 3.1.1-debug version on that system and report the results.

Jeremy

Otomatic

2021-10-07 14:35

reporter   ~0006089

Hi,
I think it's the same problem I have.
See id's 2024, 2028 and 2029

Cheers,
Dominique aka Otomatic

derick

2021-10-07 17:44

administrator   ~0006094

I think I have fixed this now, please try the right DLL from the following list of Artifacts:
https://github.com/xdebug/xdebug/actions/runs/1317223628

JeremyDunn

2021-10-07 19:24

reporter   ~0006095

Hi Derick,
Thanks VERY much for continuing work on this issue. Unfortunately the most recent version (3.2.0-dev) is still not working.

xdebug.log still contains:
[23888] Log opened at 2021-10-07 19:21:43.756952
[23888] [Config] INFO: Trigger value for 'XDEBUG_TRIGGER' not found, falling back to 'XDEBUG_SESSION'
[23888] [Config] INFO: Trigger value for 'XDEBUG_SESSION' not found, so not activating

behavior is the same as before: phpinfo(); by itself works fine; shows xdebug 3.2.0-dev is loaded; any other line of code in the file causes apache httpd to crash

JeremyDunn

2021-10-07 19:31

reporter   ~0006096

more info: I tried v3.2.0-dev on our non-production (dev/test) web server, which happens to be running Windows Server 2012 R2, apache httpd 2.4.48, and PHP 8.0.8RC1

same behavior as on my Win 10 Pro system. apache httpd crashes on execution of the file with phpinfo(); and the security clause as noted in previous comment

JeremyDunn

2021-10-07 19:38

reporter   ~0006097

Question: since I can recreate this problem on Win 10 Pro and Win Server 2012 R2, I'm curious why Christopher cannot recreate in whatever Windows environment he's running.

My thought is that something else I have installed (both locally, and on dev/test web server) might be causing the problem, which is why I tried very minimal PHP.ini and no other extensions; but this test verified it is not something in PHP environment.

I also tried removing many of the options/configs in httpd.conf, but that also seemed to have no effect.

Is there anything else you can think of that would impact XDebug ?? I don't know how to isolate the issue. Obviously once Christopher can recreate that will make things easier...

I'm happy to attach a (somewhat sanitized) httpd.conf if that would aid debugging...let me know

cmb

2021-10-08 14:49

reporter   ~0006103

I was able to reproduce with the provided PHP script (previously I only tried a phpinfo()).

See <https://gist.github.com/cmb69/de63fabbc9ebc9b160b5d094dbf4a90b> for details and a minimal patch. It might be necessary to move all of xdebug_library_minit() into xdebug_init_library_globals().

JeremyDunn

2021-10-08 14:59

reporter   ~0006104

@Christopher - great that you can reproduce and possibly fix. Unfortunately I have no skills/toolset to build xdebug locally

@Derick - please advise when there is another version I can download and try.

derick

2021-10-13 16:44

administrator   ~0006111

@JeremyDunn Christoph sniffed out the commit that caused this issue, which I have reverted for this branch/PR: https://github.com/xdebug/xdebug/actions/runs/1338217171 — care to try it?

JeremyDunn

2021-10-13 23:09

reporter   ~0006112

> Christoph sniffed out the commit that caused this issue, which I have reverted for this branch/PR: https://github.com/xdebug/xdebug/actions/runs/1338217171 — care to try it?

success !!

Thank you both for your continued efforts.
 * It now works properly to show xdebug 3.1.1-dev in phpinfo() with other statements in the same file.
 * step-debugging works properly
 * variable-inspection works properly

Seems just like the XDebug I know and love ! :-)

derick

2021-10-15 13:12

administrator   ~0006118

https://github.com/xdebug/xdebug/pull/804

Issue History

Date Modified Username Field Change
2021-09-14 18:35 JeremyDunn New Issue
2021-09-16 08:48 derick Status new => feedback
2021-09-16 08:48 derick Target Version => 3.1dev
2021-09-16 08:48 derick Note Added: 0006007
2021-09-16 09:42 JeremyDunn Note Added: 0006011
2021-09-16 09:42 JeremyDunn Status feedback => new
2021-09-16 11:32 JeremyDunn Note Added: 0006018
2021-09-16 11:32 JeremyDunn File Added: MultipleDumps_CrashHangAnalysis.mht
2021-09-20 17:53 JeremyDunn Note Added: 0006020
2021-09-22 10:06 derick Assigned To => derick
2021-09-22 10:06 derick Status new => feedback
2021-09-22 10:06 derick Note Added: 0006026
2021-09-22 10:22 derick Note Added: 0006028
2021-09-22 10:30 derick Note Edited: 0006028
2021-09-22 13:10 JeremyDunn Note Added: 0006029
2021-09-22 13:10 JeremyDunn Status feedback => assigned
2021-09-22 13:10 JeremyDunn Note Added: 0006030
2021-09-22 13:10 JeremyDunn File Added: httpd.exe_210922_084340_CrashHangAnalysis.mht
2021-09-22 14:52 derick Status assigned => feedback
2021-09-22 14:52 derick PHP Version 8.0.0-8.0.4 => 8.0.5-8.0.9
2021-09-22 14:52 derick Note Added: 0006032
2021-09-22 16:55 JeremyDunn Note Added: 0006033
2021-09-22 16:55 JeremyDunn Status feedback => assigned
2021-09-22 16:55 JeremyDunn Note Added: 0006034
2021-09-22 16:55 JeremyDunn File Added: httpd.exe_210922_120053_CrashHangAnalysis.mht
2021-09-23 13:05 derick Note Added: 0006037
2021-09-23 13:05 derick Status assigned => feedback
2021-09-23 15:59 JeremyDunn Note Added: 0006042
2021-09-23 15:59 JeremyDunn Status feedback => assigned
2021-09-23 15:59 JeremyDunn Note Added: 0006043
2021-09-23 15:59 JeremyDunn File Added: httpd.exe_210923_115403_CrashHangAnalysis.mht
2021-09-28 11:07 JeremyDunn Note Added: 0006053
2021-09-28 13:48 derick Note Added: 0006054
2021-10-04 11:51 JeremyDunn Note Added: 0006073
2021-10-05 10:35 derick Note Added: 0006078
2021-10-05 12:29 JeremyDunn Note Added: 0006080
2021-10-05 12:30 JeremyDunn Note Added: 0006081
2021-10-05 12:30 JeremyDunn File Added: Xdebug 3.1.0.htm
2021-10-05 12:30 JeremyDunn File Added: php.ini
2021-10-06 14:59 derick Status assigned => feedback
2021-10-06 14:59 derick Note Added: 0006084
2021-10-06 18:02 JeremyDunn Note Added: 0006087
2021-10-06 18:02 JeremyDunn Status feedback => assigned
2021-10-07 14:35 Otomatic Note Added: 0006089
2021-10-07 17:44 derick Note Added: 0006094
2021-10-07 19:24 JeremyDunn Note Added: 0006095
2021-10-07 19:31 JeremyDunn Note Added: 0006096
2021-10-07 19:38 JeremyDunn Note Added: 0006097
2021-10-08 14:49 cmb Note Added: 0006103
2021-10-08 14:59 JeremyDunn Note Added: 0006104
2021-10-13 16:44 derick Note Added: 0006111
2021-10-13 23:09 JeremyDunn Note Added: 0006112
2021-10-15 13:12 derick Status assigned => closed
2021-10-15 13:12 derick Resolution open => fixed
2021-10-15 13:12 derick Fixed in Version => 3.1dev
2021-10-15 13:12 derick Note Added: 0006118
2021-10-15 13:19 derick Fixed in Version 3.1dev => 3.1.1