View Issue Details

IDProjectCategoryView StatusLast Update
0002024XdebugUncategorizedpublic2021-10-15 13:19
ReporterOtomatic Assigned Toderick  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
OSWindowsOS Version10 
Product Version3.1.0beta2 
Target Version3.1devFixed in Version3.1.1 
Summary0002024: Apache restarts in a loop under PHP 8.1.0 RC3
DescriptionPHP used as a module:
PHPIniDir "${APACHE_DIR}/bin"
LoadModule php7_module "${INSTALL_DIR}/bin/php/php8.1.0/php7apache2_4.dll"

xDebug loaded as zend_extension in php.ini
; XDEBUG Extension
[xdebug]
zend_extension="E:/wamp64/bin/php/php8.1.0/zend_ext/php_xdebug-3.1.0-8.1-vs16-x86_64.dll"
;xdebug.mode allowed are : off develop coverage debug gcstats profile trace
xdebug.mode = develop
xdebug.profiler_output_name = "cachegrind.out.%t.%p"
xdebug.output_dir ="E:/wamp64/tmp"
xdebug.show_local_vars=0
Steps To ReproduceTry to load Wampserver homepage : http://localhost/
Not load:
The connection has been reset
The connection to the server was reset while the page was loading.
Additional Informationapache_error.log
[Thu Sep 30 16:43:32.024919 2021] [mpm_winnt:notice] [pid 12720:tid 792] AH00428: Parent: child process 8284 exited with status 3221225477 -- Restarting.
[Thu Sep 30 16:43:32.115464 2021] [mpm_winnt:notice] [pid 12720:tid 792] AH00455: Apache/2.4.49 (Win64) OpenSSL/1.1.1l PHP/8.1.0RC3 configured -- resuming normal operations
[Thu Sep 30 16:43:32.115464 2021] [mpm_winnt:notice] [pid 12720:tid 792] AH00456: Apache Lounge VS16 Server built: Sep 12 2021 10:23:43
[Thu Sep 30 16:43:32.115464 2021] [core:notice] [pid 12720:tid 792] AH00094: Command line: 'E:\\wamp64\\bin\\apache\\apache2.4.49\\bin\\httpd.exe -d E:/wamp64/bin/apache/apache2.4.49'
[Thu Sep 30 16:43:32.119583 2021] [mpm_winnt:notice] [pid 12720:tid 792] AH00418: Parent: Created child process 10272
[Thu Sep 30 16:43:32.587595 2021] [mpm_winnt:notice] [pid 10272:tid 712] AH00354: Child: Starting 64 worker threads.
[Thu Sep 30 16:43:33.939843 2021] [mpm_winnt:notice] [pid 12720:tid 792] AH00428: Parent: child process 10272 exited with status 3221225477 -- Restarting.
[Thu Sep 30 16:43:34.031366 2021] [mpm_winnt:notice] [pid 12720:tid 792] AH00455: Apache/2.4.49 (Win64) OpenSSL/1.1.1l PHP/8.1.0RC3 configured -- resuming normal operations
[Thu Sep 30 16:43:34.031366 2021] [mpm_winnt:notice] [pid 12720:tid 792] AH00456: Apache Lounge VS16 Server built: Sep 12 2021 10:23:43
[Thu Sep 30 16:43:34.031366 2021] [core:notice] [pid 12720:tid 792] AH00094: Command line: 'E:\\wamp64\\bin\\apache\\apache2.4.49\\bin\\httpd.exe -d E:/wamp64/bin/apache/apache2.4.49'
[Thu Sep 30 16:43:34.033364 2021] [mpm_winnt:notice] [pid 12720:tid 792] AH00418: Parent: Created child process 15140
[Thu Sep 30 16:43:34.498904 2021] [mpm_winnt:notice] [pid 15140:tid 712] AH00354: Child: Starting 64 worker threads.
[Thu Sep 30 16:43:37.928837 2021] [mpm_winnt:notice] [pid 12720:tid 792] AH00428: Parent: child process 15140 exited with status 3221225477 -- Restarting.
[Thu Sep 30 16:43:38.017709 2021] [mpm_winnt:notice] [pid 12720:tid 792] AH00455: Apache/2.4.49 (Win64) OpenSSL/1.1.1l PHP/8.1.0RC3 configured -- resuming normal operations
[Thu Sep 30 16:43:38.017709 2021] [mpm_winnt:notice] [pid 12720:tid 792] AH00456: Apache Lounge VS16 Server built: Sep 12 2021 10:23:43
[Thu Sep 30 16:43:38.017709 2021] [core:notice] [pid 12720:tid 792] AH00094: Command line: 'E:\\wamp64\\bin\\apache\\apache2.4.49\\bin\\httpd.exe -d E:/wamp64/bin/apache/apache2.4.49'
[Thu Sep 30 16:43:38.020708 2021] [mpm_winnt:notice] [pid 12720:tid 792] AH00418: Parent: Created child process 14420
and so on

With xdebug.mode = off -> No problem
TagsNo tags attached.
Operating SystemMicrosoft Windows [version 10.0.19043.1237]
PHP Version8.1-dev

Relationships

has duplicate 0002028 resolvedderick Does not works - Restart Apache 

Activities

Otomatic

2021-10-02 12:45

reporter   ~0006071

Exactly the same problem with:
- PHP 8.0.11 and php_xdebug-3.1.0beta2-8.0-vs16-x86_64.dll
- PHP 7.4.24 and php_xdebug-3.1.0beta2-7.4-vc15-x86_64.dll

Otomatic

2021-10-04 15:44

reporter   ~0006074

I'm sorry but even xdebug 3.1.0 final still doesn't work whatever the version of PHP: 7.2.34, 7.3.31, 7.4.24, 8.0.11 whether it's 32 or 64bit.

Apache restarts in a loop when we try to access a local site, for example 'http://localhost/' while it is not a problem with xdebug 3.0.4.

Totally blocking !

cmb

2021-10-05 10:22

reporter   ~0006077

> LoadModule php7_module "${INSTALL_DIR}/bin/php/php8.1.0/php7apache2_4.dll"

This can't work; that should be

LoadModule php_module "${INSTALL_DIR}/bin/php/php8.1.0/php8apache2_4.dll"

derick

2021-10-06 15:04

administrator   ~0006086

Hi,

I think we (or rather, Christopher) found a potential fix for this. Can you try the right artefact from https://github.com/xdebug/xdebug/actions/runs/1312331369 for your set-up, and see if that fixes it?

cheers,
Derick

derick

2021-10-07 17:43

administrator   ~0006093

I think I have fixed this now, please try the right DLL from the following list of Artifacts:
https://github.com/xdebug/xdebug/actions/runs/1317223628

Otomatic

2021-10-08 09:57

reporter   ~0006099

I'm sorry, but the problem is not solved.
Whatever the browser used: Firefox, Opera, Chrome, Edge, when calling 'http://localhost/' there is a restart of Apache and ERR_CONNECTION_RESET in the browser.


---- xdebug.log With xdebug 3.0.4
--- File cleaned up by Wampserver ---
--- on 2021-10-08 11:31
[13440] Log opened at 1970-01-01 00:22:52.858608
[13440] [Step Debug] INFO: Checking remote connect back address.
[13440] [Step Debug] INFO: Checking header 'HTTP_X_FORWARDED_FOR'.
[13440] [Step Debug] INFO: Checking header 'REMOTE_ADDR'.
[13440] [Step Debug] INFO: Client host discovered through HTTP header, connecting to 127.0.0.1:9003.
[13440] [Step Debug] INFO: Connected to debugging client: 127.0.0.1:9003 (from REMOTE_ADDR HTTP header). :-)
[13440] [Step Debug] -> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" fileuri="file:///E:/wamp64/www/index.php" language="PHP" xdebug:language_version="8.0.4RC1" protocol_version="1.0" appid="13440"><engine version="3.0.4"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[https://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2021 by Derick Rethans]]></copyright></init>

[13440] [Step Debug] -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" status="stopping" reason="ok"></response>

[13440] Log closed at 1970-01-01 00:22:52.858618

---- xdebug.log With xdebug 3.1.1-dev
--- File cleaned up by Wampserver ---
--- on 2021-10-08 11:35
[14360] Log opened at 2021-10-08 09:36:26.432171
[14360] [Step Debug] INFO: Checking remote connect back address.
[14360] [Step Debug] INFO: Checking header 'HTTP_X_FORWARDED_FOR'.
[14360] [Step Debug] INFO: Checking header 'REMOTE_ADDR'.
[14360] [Step Debug] INFO: Client host discovered through HTTP header, connecting to 127.0.0.1:9003.
[14360] [Step Debug] INFO: Connected to debugging client: 127.0.0.1:9003 (from REMOTE_ADDR HTTP header). :-)
[14360] [Step Debug] -> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" fileuri="file:///E:/wamp64/www/index.php" language="PHP" xdebug:language_version="8.0.11" protocol_version="1.0" appid="14360"><engine version="3.1.1-dev"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[https://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2021 by Derick Rethans]]></copyright></init>

There's something I'm curious about:
With xdebug 3.0.4 -> language="PHP" xdebug:language_version="8.0.4RC1"
With xdebug 3.1.1-dev -> language="PHP" xdebug:language_version="8.0.11"

while in both cases it is exactly the same version of PHP: 8.0.11

I can make other tests, just tell me what to do and with which configuration(s) of xdebug.

derick

2021-10-08 12:30

administrator   ~0006101

There's something I'm curious about:
With xdebug 3.0.4 -> language="PHP" xdebug:language_version="8.0.4RC1"
With xdebug 3.1.1-dev -> language="PHP" xdebug:language_version="8.0.11"

while in both cases it is exactly the same version of PHP: 8.0.11


That is because Xdebug uses the version of PHP's headers that it was compiled against, which does not have to match the version that is running. I've created a new ticket to "fix" this: 0002032

derick

2021-10-13 23:21

administrator   ~0006113

Christoph sniffed out the commit that caused this issue, which I have reverted for this branch/PR: https://github.com/xdebug/xdebug/actions/runs/1338217171 — care to try it?

derick

2021-10-13 23:22

administrator   ~0006115

Christoph sniffed out the commit that caused this issue, which I have reverted for this branch/PR: https://github.com/xdebug/xdebug/actions/runs/1338217171 — care to try it?

Otomatic

2021-10-14 07:13

reporter   ~0006116

Hi,

Try 1338217171 with PHP 8.0.11.
- It seems to work fine
- There is no longer an Apache restart on the 'http://localhost/' call
- xdebug_info() works and gives the right information
- the trace mode works
- I have also tested with PHP 8.1.0RC3 and everything seems to work fine too

In short, the problem seems to be solved.

Thank you for your help.

Otomatic

2021-10-15 08:13

reporter   ~0006117

Hi,

I don't know if this is an xDebug or PHP fault, but with PHP 8.1.0 RC4 64bit, xDebug seems to be non-existent.
- The dll "php_xdebug-3.1.1-dev-8.1-vs16-x86_64.dll" is loaded correctly and there is no Apache restart with the 'hhtp://localhost/' call.
- if(function_exists('xdebug_info')) return false
- xdebug.mode = debug,trace does not generate a log or trace file

I'm leaning towards a PHP 8.1.0 RC4 default since it worked with the same dll and PHP 8.1.0 RC3

derick

2021-10-15 13:13

administrator   ~0006119

https://github.com/xdebug/xdebug/pull/804

Issue History

Date Modified Username Field Change
2021-09-30 14:47 Otomatic New Issue
2021-10-02 12:45 Otomatic Note Added: 0006071
2021-10-04 15:44 Otomatic Note Added: 0006074
2021-10-04 17:15 derick Target Version => 3.1dev
2021-10-05 10:22 cmb Note Added: 0006077
2021-10-06 15:04 derick Assigned To => derick
2021-10-06 15:04 derick Status new => feedback
2021-10-06 15:04 derick Note Added: 0006086
2021-10-07 16:34 derick Relationship added has duplicate 0002028
2021-10-07 17:43 derick Note Added: 0006093
2021-10-08 09:57 Otomatic Note Added: 0006099
2021-10-08 09:57 Otomatic Status feedback => assigned
2021-10-08 12:30 derick Note Added: 0006101
2021-10-13 23:21 derick Note Added: 0006113
2021-10-13 23:22 derick Status assigned => feedback
2021-10-13 23:22 derick Note Added: 0006115
2021-10-14 07:13 Otomatic Note Added: 0006116
2021-10-14 07:13 Otomatic Status feedback => assigned
2021-10-15 08:13 Otomatic Note Added: 0006117
2021-10-15 13:13 derick Status assigned => closed
2021-10-15 13:13 derick Resolution open => fixed
2021-10-15 13:13 derick Fixed in Version => 3.1dev
2021-10-15 13:13 derick Note Added: 0006119
2021-10-15 13:19 derick Fixed in Version 3.1dev => 3.1.1