View Issue Details

IDProjectCategoryView StatusLast Update
0002033XdebugUncategorizedpublic2021-11-10 15:42
Reporterdimadeush Assigned Toderick  
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version3.1.0 
Summary0002033: php 8.0.11 cli fail with "Segmentation fault (core dumped)" error when xdebug xdebug.mode=develop
DescriptionHello

PHP 8.0.* cli fail with error "Segmentation fault (core dumped)" when xdebug in mode develop. Tested using PHPUNIT 9.5.* and Symfony 5.*
In case mode xdebug.mode = coverage,debug everything fine and there is no such error.
I have composer.json and composer.lock if it is necessary for investigating issue.

Please help
Thanks in Advance
TagsNo tags attached.
Operating Systemubuntu linux
PHP Version8.0.5-8.0.9

Activities

dimadeush

2021-10-10 21:40

reporter   ~0006105

My xdebug config:

[PHP]
zend_extension=xdebug

xdebug.mode = coverage,debug,develop
xdebug.client_port = 10000
xdebug.client_host = 172.17.0.1
xdebug.idekey = PHPSTORM
#xdebug.show_error_trace = 1
xdebug.start_with_request = yes
xdebug.file_link_format = phpstorm://open?%f:%l
xdebug.discover_client_host= 1
xdebug.max_nesting_level = 10000
xdebug.log_level = 0

dimadeush

2021-10-10 22:16

reporter   ~0006106

I have tried to change all params according to docs related to develop mode but nothing helped except one param:
----
xdebug.halt_level = E_WARNING|E_NOTICE|E_USER_WARNING|E_USER_NOTICE
----
With such option I have next output:
----
PHPUnit 9.5.10 by Sebastian Bergmann and contributors.

Testing

THE ERROR HANDLER HAS CHANGED!
----

derick

2021-10-18 14:05

administrator   ~0006122

Could you try Xdebug 3.1.1?

dimadeush

2021-10-27 14:21

reporter   ~0006146

Hello
The same issue now:

139(Segmentation violation)

Please help
Thanks in Advance

derick

2021-10-27 14:59

administrator   ~0006147

Then please follow the instructions at https://xdebug.org/reporting-bugs so that I have a bug report that I can do something about. I don't have not nearly enough information from you.

derick

2021-11-10 15:42

administrator   ~0006151

I can't reproduce this any more, and the requested information wasn't provided. So closing this out.

Issue History

Date Modified Username Field Change
2021-10-10 21:16 dimadeush New Issue
2021-10-10 21:40 dimadeush Note Added: 0006105
2021-10-10 22:16 dimadeush Note Added: 0006106
2021-10-18 14:05 derick Assigned To => derick
2021-10-18 14:05 derick Status new => feedback
2021-10-18 14:05 derick Note Added: 0006122
2021-10-27 14:21 dimadeush Note Added: 0006146
2021-10-27 14:21 dimadeush Status feedback => assigned
2021-10-27 14:59 derick Status assigned => feedback
2021-10-27 14:59 derick Note Added: 0006147
2021-11-10 15:42 derick Status feedback => resolved
2021-11-10 15:42 derick Resolution open => unable to reproduce
2021-11-10 15:42 derick Note Added: 0006151