View Issue Details

IDProjectCategoryView StatusLast Update
0002149XdebugStacktracespublic2022-12-21 10:47
Reporterdavidgrudl Assigned Toderick  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version3.2.0 
Summary0002149: Stack Traces are shown even when xdebug is running in mode 'debug'
Description

Xdebug overrides PHP's standard error handler callbacks and shows stack trace. But I have xdebug.mode = debug in php.ini

TagsNo tags attached.
Operating System
PHP Version8.1.10-8.1.19

Relationships

duplicate of 0002144 feedbackderick Xdebug 3.2.0 ignores xdebug.mode and enables all features 

Activities

derick

2022-12-18 14:40

administrator   ~0006492

  • Which operating system are you on?
  • Can you shared a screenshot of all of the output of a call to xdebug_info();

davidgrudl

2022-12-19 12:46

reporter   ~0006494

I have WIndows 11 Pro. Here is screenshot of result of this code, so you can see stack trace at bottom:

<?php
declare(strict_types=1);
xdebug_info();
$a++;

derick

2022-12-21 10:47

administrator   ~0006497

I believe this is a duplicate of 0002144. I think I know where the problem lies, but figuring how to fix it, and how to not un-fix the fix that I made this change for, is trickier.

Issue History

Date Modified Username Field Change
2022-12-17 17:04 davidgrudl New Issue
2022-12-18 14:40 derick Assigned To => derick
2022-12-18 14:40 derick Status new => feedback
2022-12-18 14:40 derick Note Added: 0006492
2022-12-19 12:46 davidgrudl Note Added: 0006494
2022-12-19 12:46 davidgrudl File Added: Screenshot 2022-12-19 at 13-44-34 Xdebug 3.2.0.png
2022-12-19 12:46 davidgrudl Status feedback => assigned
2022-12-21 10:47 derick Status assigned => resolved
2022-12-21 10:47 derick Resolution open => duplicate
2022-12-21 10:47 derick Note Added: 0006497
2022-12-21 10:47 derick Relationship added duplicate of 0002144