View Issue Details

IDProjectCategoryView StatusLast Update
0000235Xdebug(No Category)public2009-11-27 17:08
ReporterjeffgAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000235: php crash on Vista w/Komodo
Descriptionrepro:
 - install Komodo 4 with php 5.2 on Vista
 - step into any file, then switch to the 'superglobals' debugger tab
 - Vista reports that php has crashed
TagsNo tags attached.
Operating System
PHP Version5.2.0

Activities

derick

2007-01-19 09:57

administrator   ~0000550

I only have Komodo 3, and no Windows whatsoever.I tried to reproduce this on Linux (with Komodo 3) and a script running with valgrind/php, but it is working perfectly. Could you please supply the script *and* most importantly the remote debug log (-dxdebug.remote_log=c:\...)? Perhaps Komodo 4 sends a different query for the superglobals.

derick

2007-01-29 20:01

administrator   ~0000560

Reminder sent to jeffg

I only have Komodo 3, and no Windows whatsoever.I tried to reproduce this on Linux (with Komodo 3) and a script running with valgrind/php, but it is working perfectly. Could you please supply the script *and* most importantly the remote debug log (-dxdebug.remote_log=c:\...)? Perhaps Komodo 4 sends a different query for the superglobals.

jeffg

2007-09-28 00:08

reporter   ~0000728

Sorry for not getting back regarding this bug. It does still exist and I am wondering how to proceed with it. Some more points:
 - it only ever happens on Vista, testing on linux is pointless
 - on Vista it happens every time

Is there some information I can get you from our test machine that will help sort this out? I have little experience debugging PHP extensions on Windows.

jeffg

2007-09-29 00:07

reporter   ~0000729

We looked a bit more at this today with frustrating results. Our idea was to build a debug build of xdebu on windows and try to attach to the php-cgi process with Visual Studio to catch the crash. We can do this but never get the debug symbols etc to display, all we get is the assembler stack.

The actual crash happens deep in ntdll so I imagine this is due to a difference between Vista and XP/previous windows.

neraath

2007-09-29 06:02

reporter   ~0000730

I likewise have this problem. However, I don't even have to click on the superglobals debugger tab. I just start debugging and it crashes on me. Here's some information I have from Visual Studio:

'php.exe': Loaded 'C:\xampp\php\php.exe', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\ntdll.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\kernel32.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\php5ts.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\oleaut32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\ole32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\msvcrt.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\gdi32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\user32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\advapi32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\rpcrt4.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\odbc32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\winsxs\x86_microsoft.windows.common-controls_6595b64144ccf1df_5.82.6000.16386_none_87e0cb09378714f1\comctl32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\shell32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\shlwapi.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\comdlg32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\ws2_32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\nsi.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\imm32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\msctf.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\lpk.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\usp10.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\winsxs\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.6000.16386_none_5d07289e07e1d100\comctl32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\odbcint.dll', Binary was not built with debug information.
'php.exe': Loaded 'C:\xampp\php\ext\php_xdebug.dll', Binary was not built with debug information.
'php.exe': Loaded 'C:\xampp\php\ext\php_curl.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ssleay32.dll', Binary was not built with debug information.
'php.exe': Loaded 'C:\xampp\php\libeay32.dll', Binary was not built with debug information.
'php.exe': Loaded 'C:\Windows\System32\wsock32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\winmm.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\oleacc.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_gd2.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_gettext.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_imap.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\secur32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\crypt32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\msasn1.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\userenv.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_mbstring.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_exif.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_mcrypt.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\libmcrypt.dll', Binary was not built with debug information.
'php.exe': Loaded 'C:\xampp\php\ext\php_mcrypt_filter.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_mime_magic.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_ming.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_mssql.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ntwdblib.dll', Cannot find or open a required DBG file.
'php.exe': Loaded 'C:\Windows\System32\netapi32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\psapi.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_mysql.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\libmysql.dll', Binary was not built with debug information.
'php.exe': Loaded 'C:\xampp\php\ext\php_mysqli.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_openssl.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_pdf.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_pdo.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_pdo_mssql.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_pdo_mysql.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_pdo_sqlite.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_pgsql.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_soap.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_sockets.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_sqlite.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_xmlrpc.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_xsl.dll', No symbols loaded.
'php.exe': Loaded 'C:\xampp\php\ext\php_zip.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\credssp.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\schannel.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\nlaapi.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\IPHLPAPI.DLL', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\dhcpcsvc.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\dnsapi.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\winnsi.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\dhcpcsvc6.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\mswsock.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\winrnr.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\Wldap32.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\NapiNSP.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\pnrpnsp.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\rasadhlp.dll', No symbols loaded.
'php.exe': Loaded 'C:\Windows\System32\WSHTCPIP.DLL', No symbols loaded.
The thread 'Win32 Thread' (0x15ec) has exited with code 0 (0x0).
Unhandled exception at 0x77af2086 in php.exe: 0xC0000005: Access violation reading location 0x032bf6f4.

I have no idea what I'm looking at when I look at a disassembly, but here's some of the information around it (asterisk is the break point):

77AF2072 mov eax,dword ptr [edi]
77AF2074 mov esi,edi
77AF2076 shr esi,3
77AF2079 xor esi,eax
77AF207B xor esi,dword ptr ds:[77B55284h]
77AF2081 mov dword ptr [ebp-4],edi
77AF2084 xor esi,ecx
* 77AF2086 mov eax,dword ptr [esi+4]
77AF2089 mov dword ptr [ebp-0Ch],eax
77AF208C mov byte ptr [edi+7],80h
77AF2090 mov byte ptr [edi+6],0
77AF2094 mov ebx,dword ptr [esi+8]
77AF2097 mov ecx,dword ptr [esi+0Ch]
77AF209A mov dword ptr [ebp-20h],ebx
77AF209D add ebx,1
77AF20A0 mov dword ptr [ebp-1Ch],ecx

jeffg

2007-10-01 18:35

reporter   ~0000731

@nerath: The dissasembly won't help because the Windows xdebug builds are stripped of symbols. I have tried to build xdebug as a 'debug' build in Visual Studio, but still don't see anything but the disassembly. I am no wizard with debugging C code on Windows though.

jeffg

2007-10-01 20:25

reporter   ~0000732

Using the instructions from this post:

http://blog.thepimp.net/index.php/tag/windows

using: php 5.2.3 and the 'debug pack'

I have what I think is more info on the crash:

Report for php-cgi__PID__276__Date__10_01_2007__Time_12_19_23PM__100__Second_Chance_Exception_C0000005.dmp
Type of Analysis Performed Crash Analysis
Machine Name OPUSWOW
Operating System Windows Vista
Number Of Processors 2
Process ID 276
Process Image C:\Users\jeffg\Desktop\php-test\php-5.2.3-Win32\php-cgi.exe
System Up-Time 00:22:40
Process Up-Time 00:01:48


Thread 0 - System ID 3132
Entry point php_cgi!mainCRTStartup
Create time 10/1/2007 12:17:35 PM
Time spent in user mode 0 Days 0:0:0.0
Time spent in kernel mode 0 Days 0:0:0.15






Function Arg 1 Arg 2 Arg 3 Source
ntdll!RtlpLowFragHeapFree+31 0209fd40 00000000 024b0a60
ntdll!RtlFreeHeap+101 012c0000 00000000 0209fd38
kernel32!HeapFree+14 012c0000 00000000 0209fd40
php_xdebug!xdebug_zend_shutdown+f3a2 0209fd40 024b3d80 003d62b4
php_xdebug!xdebug_zend_shutdown+f1d8 024b4010 024b3c68 003d6272
php_xdebug!xdebug_zend_shutdown+f244 024b3d80 024b3b50 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b3c68 024b3a38 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b3b50 024b3920 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b3a38 024b3808 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b3920 024b36c0 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b3808 024b35d0 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b36c0 024b34b8 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b35d0 024b33a0 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b34b8 024b3288 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b33a0 024b3170 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b3288 024b3080 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b3170 024b2f68 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b3080 024b2e20 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b2f68 024b2d08 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b2e20 024b2bf0 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b2d08 024b2ab0 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b2bf0 024b2998 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b2ab0 024b2880 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b2998 024b2768 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b2880 024b25f8 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b2768 024b24e0 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b25f8 024b23c8 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b24e0 024b22b0 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b23c8 024b2148 003d6282
php_xdebug!xdebug_zend_shutdown+f202 024b22b0 024b2030 003d6272
php_xdebug!xdebug_zend_shutdown+f212 024b2148 024b0f60 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b2030 024b0e48 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b0f60 024b0d30 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b0e48 024b0c18 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b0d30 024b0a10 003d6272
php_xdebug!xdebug_zend_shutdown+f202 024b0c18 024b08f8 003d6282
php_xdebug!xdebug_zend_shutdown+f202 024b0a10 024b08f8 003cdb78
php_xdebug!xdebug_zend_shutdown+f212 024b08f8 00000000 000d1560
php_xdebug!xdebug_zend_shutdown+6b08 02078bcc 000d1560 024b08f8
php_xdebug!xdebug_zend_shutdown+7848 02078bcc 012ccd10 01e0a508
php_xdebug!xdebug_statement_call+18a 01e0a438 100a6802 01fe9480
php5ts!zend_extension_statement_handler+12 01fe9480 01e0a438 000d1560
php5ts!zend_llist_apply_with_argument+22 104b0880 1001de50 01e0a438
php5ts!ZEND_EXT_STMT_SPEC_HANDLER+33 00c0db8c 000d1560 01e0a438
php5ts!ZEND_USER_OPCODE_SPEC_HANDLER+53 00c0db8c 000d1560 000d1560
php5ts!execute+1c5 01e0a438 000d1560 01e093f5
php_xdebug!get_module+1cd9 00000000 00000000 00000000




NTDLL!RTLPLOWFRAGHEAPFREE+31In php-cgi__PID__276__Date__10_01_2007__Time_12_19_23PM__100__Second_Chance_Exception_C0000005.dmp the assembly instruction at ntdll!RtlpLowFragHeapFree+31 in C:\Windows\System32\ntdll.dll from Microsoft Corporation has caused an access violation exception (0xC0000005) when trying to read from memory location 0x0326ef74 on thread 0

Module Information
Image Name: C:\Windows\System32\ntdll.dll Symbol Type: PDB
Base address: 0x77b60000 Time Stamp: Thu Nov 02 02:43:37 2006
Checksum: 0x00128171 Comments:
COM DLL: False Company Name: Microsoft Corporation
ISAPIExtension: False File Description: NT Layer DLL
ISAPIFilter: False File Version: 6.0.6000.16386 (vista_rtm.061101-2205)
Managed DLL: False Internal Name: ntdll.dll
VB DLL: False Legal Copyright: © Microsoft Corporation. All rights reserved.
Loaded Image Name: ntdll.dll Legal Trademarks:
Mapped Image Name: Original filename: ntdll.dll
Module name: ntdll Private Build:
Single Threaded: False Product Name: Microsoft® Windows® Operating System
Module Size: 1.12 MBytes Product Version: 6.0.6000.16386
Symbol File Name: c:\symcache\ntdll.pdb\C0A498F0036E4D4FB5CBF69005B0F9242\ntdll.pdb Special Build: &

jeffg

2007-10-01 20:40

reporter   ~0000733

@neraath if you follow the steps to get the crash analysis on your system, what results do you get?

jeffg

2007-11-30 22:12

reporter   ~0000818

This seems to have cleared up in recent builds, tested with php 5.2.5 only so far.

derick

2009-11-27 17:08

administrator   ~0001183

"This seems to have cleared up in recent builds, tested with php 5.2.5 only so far. "

Issue History

Date Modified Username Field Change
2007-01-19 02:07 jeffg New Issue
2007-01-19 09:57 derick Note Added: 0000550
2007-01-19 09:57 derick Status new => feedback
2007-01-29 20:01 derick Note Added: 0000560
2007-09-28 00:08 jeffg Note Added: 0000728
2007-09-29 00:07 jeffg Note Added: 0000729
2007-09-29 06:02 neraath Note Added: 0000730
2007-10-01 18:35 jeffg Note Added: 0000731
2007-10-01 20:25 jeffg Note Added: 0000732
2007-10-01 20:40 jeffg Note Added: 0000733
2007-11-30 22:12 jeffg Note Added: 0000818
2009-11-27 17:08 derick Note Added: 0001183
2009-11-27 17:08 derick Status feedback => resolved
2009-11-27 17:08 derick Resolution open => fixed
2009-11-27 17:08 derick Assigned To => derick
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)