View Issue Details

IDProjectCategoryView StatusLast Update
0000295XdebugUsage problems (Wrong Results)public2007-07-16 19:40
ReporterletssurfAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000295: __get causes memory leak
DescriptionThe following code causes a memory leak, if I disable xdebug the memory leak no longer occurs.
Additional Information<?php

class test1 {
    public function __get($name) {
        return;
    }
}


$test = new test1();

while(true) {
    $test->test;
}

TagsNo tags attached.
Operating SystemRed Hat Enterprise Linux ES release 4
PHP Version5.2.1

Relationships

duplicate of 0000290 closed Function call leaks memory 

Activities

derick

2007-07-16 19:40

administrator   ~0000698

I think this is the same as bug 0000290, which is fixed in CVS. Could you please try the latest CVS version (See http://xdebug.org/docs/install#source for instructions). I can also not reproduce this problem (anymore).

http://bugs.xdebug.org/bug_view_page.php?bug_id=0000290

Issue History

Date Modified Username Field Change
2007-07-16 16:46 letssurf New Issue
2007-07-16 19:40 derick Status new => resolved
2007-07-16 19:40 derick Resolution open => duplicate
2007-07-16 19:40 derick Relationship added duplicate of 0000290
2007-07-16 19:40 derick Assigned To => derick
2007-07-16 19:40 derick Note Added: 0000698
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)