View Issue Details

IDProjectCategoryView StatusLast Update
0000339Xdebugpublic2011-09-26 07:42
Reportersgehrig Assigned Toderick  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
Target Version2.2dev 
Summary0000339: Segmentation fault in PHP interactive mode
DescriptionWhen running PHP in interactive mode (php -a) PHP runs into a segmentation fault, when including an external file. The same script runs without problems when being run from a file. Removing the Xdebug extension also solves the problem.

Additional Informationuser@server:~> php -v
PHP 5.2.4 (cli) (built: Nov 13 2007 09:37:45)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with Xdebug v2.0.2, Copyright (c) 2002-2007, by Derick Rethans
user@server:~> php -a
Interactive mode enabled

<?php
require 'Zend/Cache.php';
Segmentation fault

user@server:~> less test.php
<?php
require 'Zend/Loader.php';
echo 'Test' . PHP_EOL;
?>
user@server:~> php test.php
Test
user@server:~>
TagsNo tags attached.
Operating SystemSUSE Linux 9.3
PHP Version5.2.4

Activities

derick

2011-09-25 22:36

administrator   ~0001815

This seems to work fine with Xdebug 2.1.2. Is this still an issue?

sgehrig

2011-09-26 06:57

reporter   ~0001816

Hi Derick,

don't think this is relevant any more. After switching to PHP 5.3 and a more recent XDebug version I cannot reproduce the issue.

Best regards

Stefan

derick

2011-09-26 07:42

administrator   ~0001817

Cheers. Closing it then.

Issue History

Date Modified Username Field Change
2007-11-22 09:40 sgehrig New Issue
2010-03-20 23:47 derick Target Version => 2.2dev
2011-09-25 22:36 derick Note Added: 0001815
2011-09-25 22:36 derick Assigned To => derick
2011-09-25 22:36 derick Status new => feedback
2011-09-26 06:57 sgehrig Note Added: 0001816
2011-09-26 06:57 sgehrig Status feedback => assigned
2011-09-26 07:42 derick Note Added: 0001817
2011-09-26 07:42 derick Status assigned => resolved
2011-09-26 07:42 derick Resolution open => no change required
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)