View Issue Details

IDProjectCategoryView StatusLast Update
0000350XdebugInstallationpublic2009-11-27 17:06
ReportersnowkrashAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000350: Apache crashes with xdebug 2.0.2 as Zend ext. on Vista
Descriptionai code reference to additional information.

Xdebug 2.0.2 for PHP 5.2.1-5.2.7 installed as an Zend extension on Vista, PHP5, Apache 2.2.6 as a Windows service (XAMPP Windows 1.6.5).

If default xdebug 2.0.2 is used (shipped with XAMPP Windows 1.6.5) (see php.ini: ai1) then everything works fine.

But if I use the downloaded version and set it in php.ini (ai2), of course I commented out the original version, then Apache crashes (ai3). Not immediately, it loads normally, but after a few requests.
Additional Information=========== ai1, default extension:
extension=php_xdebug.dll

=========== ai2, zend extensions:
zend_extension_ts = "C:\Software\XAMPP\php\ext\php_xdebug-2.0.2-5.2.5.dll"
zend_extension_ts = "C:\Software\XAMPP\php\zendOptimizer\lib\ZendExtensionManager.dll"
;zend_extension_manager.optimizer_ts = "C:\Software\XAMPP\php\zendOptimizer\lib\Optimizer"

Optimizer is commmented out in favour of eAccelerator 0.9.5.2
=========== NOTE:
The same configuration on Windows XP SP2 (5.1.2600) works fine.

=========== ai3, Windows log message:
Fault bucket 610686553, type 1
Name event: APPCRASH
answer: None
Id of CAB-file: 0

Problem signature:
P1: apache.exe
P2: 2.2.6.0
P3: 47319811
P4: php_xdebug-2.0.2-5.2.5.dll
P5: 2.0.2.0
P6: 4737295b
P7: c0000005
P8: 00006e21
P9:
P10:

Inserted files:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\Report0d69929e\WER82E5.tmp.version.txt
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\Report0d69929e\WER82E6.tmp.appcompat.txt
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\Report0d69929e\WER84CB.tmp.hdmp
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\Report0d69929e\WER91A8.tmp.mdmp

These files may be available:
C:\ProgramData\Microsoft\Windows\WER\ReportArchive\Report0e11bad6

=========== ai4, Windows fault message:
Application with error apache.exe, version 2.2.6.0, timestamp 0x47319811, module with error ntdll.dll, version 6.0.6000.16386, timestamp 0x4549bdc9, exceptioncode 0xc0000005, errormargin 0x000620e3, proces-id 0xdf4, application starttime 0x01c86253f8617de4.
TagsNo tags attached.
Operating SystemWindows Vista (Windows 6.0.6000)
PHP Version5.2.5

Relationships

duplicate of 0000410 closed Apache crashes on Vista with xDebug installed 

Activities

eric

2008-05-14 17:50

reporter   ~0000853

httpd__PID__704__Date__05_14_2008__Time_12_42_20PM__556__Second_Chance_Exception_C0000005.dmp
Type of Analysis Performed Crash Analysis
Machine Name ERIC-DESKTOP
Operating System Windows Vista Service Pack 1
Number Of Processors 2
Process ID 704
Process Image C:\Program Files\Apache Software Foundation\Apache2.2\bin\httpd.exe
System Up-Time 02:25:46
Process Up-Time 00:12:48


Thread 5 - System ID 5720
Entry point msvcrt!_endthreadex+6f
Create time 5/14/2008 12:29:32 PM
Time spent in user mode 0 Days 0:0:0.0
Time spent in kernel mode 0 Days 0:0:0.0






Function Arg 1 Arg 2 Arg 3 Source
php_xdebug!xdebug_init_oparray+23 04e1e698 00f69582 0181fc80
php5ts!zend_extension_op_array_ctor_handler+12 0181fc80 04e1e698 0430def8
php5ts!zend_llist_apply_with_argument+22 013873e0 00f6d010 04e1e698
php5ts!init_op_array+dc 04e1e698 00000002 00000040
php5ts!compile_file+b6 01fffe68 00000008 0430de00
php_xdebug!get_module+5077 00000000 00000000 00000000




PHP_XDEBUG!XDEBUG_INIT_OPARRAY+23WARNING - DebugDiag was not able to locate debug symbols for php_xdebug.dll, so the information below may be incomplete.



In httpd__PID__704__Date__05_14_2008__Time_12_42_20PM__556__Second_Chance_Exception_C0000005.dmp the assembly instruction at php_xdebug!xdebug_init_oparray+23 in c:\php\ext\php_xdebug.dll from Derick Rethans has caused an access violation exception (0xC0000005) when trying to write to memory location 0x00000000 on thread 5

Module Information
Image Name: c:\php\ext\php_xdebug.dll Symbol Type: Export
Base address: 0x001b0000 Time Stamp: Wed Apr 09 10:59:05 2008
Checksum: 0x00000000 Comments: Thanks to Derick Rethans, Ilia Alshanetsky, Harald Radi
COM DLL: False Company Name: Derick Rethans
ISAPIExtension: False File Description: Xdebug
ISAPIFilter: False File Version: 2.0.3
Managed DLL: False Internal Name: php_xdebug.dll
VB DLL: False Legal Copyright: Copyright © 2002-2008 Derick Rethans
Loaded Image Name: php_xdebug.dll Legal Trademarks:
Mapped Image Name: Original filename: php_xdebug.dll
Module name: php_xdebug Private Build:
Single Threaded: False Product Name: Xdebug
Module Size: 160.00 KBytes Product Version: 2.0.3
Symbol File Name: php_xdebug.dll Special Build: &

Issue History

Date Modified Username Field Change
2008-01-29 10:39 snowkrash New Issue
2008-05-14 17:50 eric Note Added: 0000853
2009-11-27 17:06 derick Relationship added duplicate of 0000410
2009-11-27 17:06 derick Duplicate ID 0 => 410
2009-11-27 17:06 derick Status new => resolved
2009-11-27 17:06 derick Resolution open => duplicate
2009-11-27 17:06 derick Assigned To => derick