View Issue Details

IDProjectCategoryView StatusLast Update
0000371XdebugUsage problems (Wrong Results)public2010-04-02 11:54
ReporterjoostpluijmersAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target Version2.1.0RC1Fixed in Version 
Summary0000371: Browser keeps loading
DescriptionI have two identical debug setups configured with xdebug/eclipse/php. The one I got configured at work, works perfectly and after walking trough the breakpoints it loads the page in firefox correctly.

However when i installed this configuration at home it didn't work the same. The script stopped execution at the breakpoints and I can see the variables and all but when iam done debuging the page doesn't continue loading.

I tracked down the versions I have at work down to the minor versions and it still produces the same problem. The only real difference i can think of now is the hardware specifications, I have a dualcore setup at home and a legacy amd at work.
Additional InformationMy software versions:
PHP 5.1.6
Xdebug 2.0.2
Eclipse 3.3.1.1
Apache 2.0

Hardware specification:
- Intel dualcore 6750
- ASUS P5K-E wifi/ap edition

Xdebug configuration:
xdebug.remote_enabled=1
xdebug.remote_host="myip between quotes"
xdebug.remote_port=9000
xdebug.remote_handler="dbgp"
xdebug.remote_mode="req"

A phpinfo() verify all directives are handled and set correctly to php.

If a remote_log is required I will upload it tonight when I get back from work.

Many thanks in advance

TagsNo tags attached.
Operating SystemWindows XP service pack 2
PHP Version5.1.6

Activities

derick

2008-04-29 12:47

administrator   ~0000846

The remote_log would be really useful, could you please create one? Also, could you provide a link to your phpinfo() output?

joostpluijmers

2008-05-02 12:55

reporter   ~0000847

REMOTE_LOG:
Log opened at 2008-05-02 11:53:57
-> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///C:/wamp/www/zend/index.php" language="PHP" protocol_version="1.0" appid="1608" idekey="ECLIPSE_DBGP"><engine version="2.0.3"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2008 by Derick Rethans]]></copyright></init>

<- feature_set -i 18 -n show_hidden -v 1
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="18" feature="show_hidden" success="1"></response>

<- feature_set -i 19 -n max_depth -v 3
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="19" feature="max_depth" success="1"></response>

<- feature_get -i 20 -n max_children
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_get" transaction_id="20" feature_name="max_children" supported="1"><![CDATA[32]]></response>

<- feature_get -i 21 -n encoding
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_get" transaction_id="21" feature_name="encoding" supported="1"><![CDATA[iso-8859-1]]></response>

<- feature_get -i 22 -n supports_async
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_get" transaction_id="22" feature_name="supports_async" supported="1"><![CDATA[0]]></response>

<- breakpoint_set -i 23 -t line -f file:///application/controllers/IndexController.php -n 14
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="23" id="16080003"></response>

<- breakpoint_set -i 24 -t line -f file:///Zend/View/Helper/HeadStyle.php -n 100
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="24" id="16080004"></response>

<- run -i 25
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="run" transaction_id="25" status="break" reason="ok"><xdebug:message filename="file:///C:/wamp/www/zend/Zend/View/Helper/HeadStyle.php" lineno="100"></xdebug:message></response>

<- stack_get -i 26
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="stack_get" transaction_id="26"><stack where="Zend_View_Helper_HeadStyle->headStyle" level="0" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Helper/HeadStyle.php" lineno="100"></stack><stack where="call_user_func_array" level="1" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Abstract.php" lineno="0"></stack><stack where="Zend_View_Abstract->__call" level="2" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Abstract.php" lineno="300"></stack><stack where="Zend_View->headStyle" level="3" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Abstract.php" lineno="0"></stack><stack where="IndexController->indexAction" level="4" type="file" filename="file:///C:/wamp/www/zend/application/controllers/IndexController.php" lineno="11"></stack><stack where="Zend_Controller_Action->dispatch" level="5" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Action.php" lineno="502"></stack><stack where="Zend_Controller_Dispatcher_Standard->dispatch" level="6" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Dispatcher/Standard.php" lineno="293"></stack><stack where="Zend_Controller_Front->dispatch" level="7" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Front.php" lineno="914"></stack><stack where="require" level="8" type="file" filename="file:///C:/wamp/www/zend/application/bootstrap.php" lineno="39"></stack><stack where="{main}" level="9" type="file" filename="file:///C:/wamp/www/zend/index.php" lineno="2"></stack></response>

<- stack_get -i 27
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="stack_get" transaction_id="27"><stack where="Zend_View_Helper_HeadStyle->headStyle" level="0" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Helper/HeadStyle.php" lineno="100"></stack><stack where="call_user_func_array" level="1" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Abstract.php" lineno="0"></stack><stack where="Zend_View_Abstract->__call" level="2" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Abstract.php" lineno="300"></stack><stack where="Zend_View->headStyle" level="3" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Abstract.php" lineno="0"></stack><stack where="IndexController->indexAction" level="4" type="file" filename="file:///C:/wamp/www/zend/application/controllers/IndexController.php" lineno="11"></stack><stack where="Zend_Controller_Action->dispatch" level="5" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Action.php" lineno="502"></stack><stack where="Zend_Controller_Dispatcher_Standard->dispatch" level="6" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Dispatcher/Standard.php" lineno="293"></stack><stack where="Zend_Controller_Front->dispatch" level="7" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Front.php" lineno="914"></stack><stack where="require" level="8" type="file" filename="file:///C:/wamp/www/zend/application/bootstrap.php" lineno="39"></stack><stack where="{main}" level="9" type="file" filename="file:///C:/wamp/www/zend/index.php" lineno="2"></stack></response>

<- run -i 28
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="run" transaction_id="28" status="break" reason="ok"><xdebug:message filename="file:///C:/wamp/www/zend/application/controllers/IndexController.php" lineno="14"></xdebug:message></response>

<- stack_get -i 29
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="stack_get" transaction_id="29"><stack where="IndexController->indexAction" level="0" type="file" filename="file:///C:/wamp/www/zend/application/controllers/IndexController.php" lineno="14"></stack><stack where="Zend_Controller_Action->dispatch" level="1" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Action.php" lineno="502"></stack><stack where="Zend_Controller_Dispatcher_Standard->dispatch" level="2" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Dispatcher/Standard.php" lineno="293"></stack><stack where="Zend_Controller_Front->dispatch" level="3" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Front.php" lineno="914"></stack><stack where="require" level="4" type="file" filename="file:///C:/wamp/www/zend/application/bootstrap.php" lineno="39"></stack><stack where="{main}" level="5" type="file" filename="file:///C:/wamp/www/zend/index.php" lineno="2"></stack></response>

<- stack_get -i 30
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="stack_get" transaction_id="30"><stack where="IndexController->indexAction" level="0" type="file" filename="file:///C:/wamp/www/zend/application/controllers/IndexController.php" lineno="14"></stack><stack where="Zend_Controller_Action->dispatch" level="1" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Action.php" lineno="502"></stack><stack where="Zend_Controller_Dispatcher_Standard->dispatch" level="2" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Dispatcher/Standard.php" lineno="293"></stack><stack where="Zend_Controller_Front->dispatch" level="3" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Front.php" lineno="914"></stack><stack where="require" level="4" type="file" filename="file:///C:/wamp/www/zend/application/bootstrap.php" lineno="39"></stack><stack where="{main}" level="5" type="file" filename="file:///C:/wamp/www/zend/index.php" lineno="2"></stack></response>

<- run -i 31
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="run" transaction_id="31" status="break" reason="ok"><xdebug:message filename="file:///C:/wamp/www/zend/Zend/View/Helper/HeadStyle.php" lineno="100"></xdebug:message></response>

<- stack_get -i 32
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="stack_get" transaction_id="32"><stack where="Zend_View_Helper_HeadStyle->headStyle" level="0" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Helper/HeadStyle.php" lineno="100"></stack><stack where="call_user_func_array" level="1" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Abstract.php" lineno="0"></stack><stack where="Zend_View_Abstract->__call" level="2" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Abstract.php" lineno="300"></stack><stack where="Zend_View->headStyle" level="3" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Abstract.php" lineno="0"></stack><stack where="include" level="4" type="file" filename="file:///C:/wamp/www/zend/application/layout/template.phtml" lineno="7"></stack><stack where="Zend_View->_run" level="5" type="file" filename="file:///C:/wamp/www/zend/Zend/View.php" lineno="46"></stack><stack where="Zend_View_Abstract->render" level="6" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Abstract.php" lineno="769"></stack><stack where="Zend_Layout->render" level="7" type="file" filename="file:///C:/wamp/www/zend/Zend/Layout.php" lineno="728"></stack><stack where="Zend_Layout_Controller_Plugin_Layout->postDispatch" level="8" type="file" filename="file:///C:/wamp/www/zend/Zend/Layout/Controller/Plugin/Layout.php" lineno="142"></stack><stack where="Zend_Controller_Plugin_Broker->postDispatch" level="9" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Plugin/Broker.php" lineno="337"></stack><stack where="Zend_Controller_Front->dispatch" level="10" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Front.php" lineno="925"></stack><stack where="require" level="11" type="file" filename="file:///C:/wamp/www/zend/application/bootstrap.php" lineno="39"></stack><stack where="{main}" level="12" type="file" filename="file:///C:/wamp/www/zend/index.php" lineno="2"></stack></response>

<- stack_get -i 33
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="stack_get" transaction_id="33"><stack where="Zend_View_Helper_HeadStyle->headStyle" level="0" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Helper/HeadStyle.php" lineno="100"></stack><stack where="call_user_func_array" level="1" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Abstract.php" lineno="0"></stack><stack where="Zend_View_Abstract->__call" level="2" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Abstract.php" lineno="300"></stack><stack where="Zend_View->headStyle" level="3" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Abstract.php" lineno="0"></stack><stack where="include" level="4" type="file" filename="file:///C:/wamp/www/zend/application/layout/template.phtml" lineno="7"></stack><stack where="Zend_View->_run" level="5" type="file" filename="file:///C:/wamp/www/zend/Zend/View.php" lineno="46"></stack><stack where="Zend_View_Abstract->render" level="6" type="file" filename="file:///C:/wamp/www/zend/Zend/View/Abstract.php" lineno="769"></stack><stack where="Zend_Layout->render" level="7" type="file" filename="file:///C:/wamp/www/zend/Zend/Layout.php" lineno="728"></stack><stack where="Zend_Layout_Controller_Plugin_Layout->postDispatch" level="8" type="file" filename="file:///C:/wamp/www/zend/Zend/Layout/Controller/Plugin/Layout.php" lineno="142"></stack><stack where="Zend_Controller_Plugin_Broker->postDispatch" level="9" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Plugin/Broker.php" lineno="337"></stack><stack where="Zend_Controller_Front->dispatch" level="10" type="file" filename="file:///C:/wamp/www/zend/Zend/Controller/Front.php" lineno="925"></stack><stack where="require" level="11" type="file" filename="file:///C:/wamp/www/zend/application/bootstrap.php" lineno="39"></stack><stack where="{main}" level="12" type="file" filename="file:///C:/wamp/www/zend/index.php" lineno="2"></stack></response>

<- run -i 34
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="run" transaction_id="34" status="stopping" reason="ok"></response>

I actualy downgraded apache and php to a version i know to be working at work. Firefox is head version both at home and work. Thanks for the reply

joostpluijmers

2008-05-02 12:56

reporter   ~0000848

I have set up a local forwarding to my server so phpinfo is available at http://81.207.201.40/

derick

2010-03-20 23:58

administrator   ~0001400

If this is still an issue, can you please try xdebug 2.1.0beta3 from http://xdebug.org/download.php ?

derick

2010-04-02 11:54

administrator   ~0001424

Can't reproduce, and no feedback given.

Issue History

Date Modified Username Field Change
2008-04-29 09:26 joostpluijmers New Issue
2008-04-29 12:47 derick Note Added: 0000846
2008-04-29 12:47 derick Status new => feedback
2008-05-02 12:55 joostpluijmers Note Added: 0000847
2008-05-02 12:56 joostpluijmers Note Added: 0000848
2010-03-20 23:50 derick Target Version => 2.1.0RC1
2010-03-20 23:58 derick Note Added: 0001400
2010-04-02 11:54 derick Note Added: 0001424
2010-04-02 11:54 derick Status feedback => resolved
2010-04-02 11:54 derick Resolution open => unable to reproduce
2010-04-02 11:54 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)