View Issue Details

IDProjectCategoryView StatusLast Update
0000378Xdebug(No Category)public2009-12-29 21:34
ReporterRadek MatousAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000378: Wrong lineno as response of stack_get when status=break (type return)
Description- in state=break
- breakpoint of type "return"
- command stack_get level=0
- get as a response wrong lineno (see additional information)

Always reproducible
 
Additional Informationcode:
<?php
    function mfunc() {
        echo __FILE__;
        echo __LINE__;
    }
    mfunc();
?>


snipped log (see lineno="136982130"):
...
<- breakpoint_set -i 1 -t return -s enabled -m mfunc
...
<- run -i 2
-> <response ... status="break" reason="ok"><xdebug:message ...lineno="6"...
<- stack_get -i 3
-> <response ... <stack where="mfunc" level="0" type="file" filename=... lineno="136982130"...
TagsNo tags attached.
Operating SystemPHP Version => 5.2.3-1ubuntu6.3
PHP Version5.2.3

Activities

derick

2009-12-29 21:34

administrator   ~0001235

This doesn't seem to be a problem any more, I think I fixed this some time ago. Please reopen if this is still an issue with Xdebug from SVN.

Issue History

Date Modified Username Field Change
2008-06-24 11:04 Radek Matous New Issue
2009-12-29 21:34 derick Note Added: 0001235
2009-12-29 21:34 derick Status new => resolved
2009-12-29 21:34 derick Resolution open => unable to reproduce
2009-12-29 21:34 derick Assigned To => derick
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)