View Issue Details

IDProjectCategoryView StatusLast Update
0000387XdebugUncategorizedpublic2009-11-27 17:03
ReportersnopAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityrandom
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000387: xdebug 2.0.3 causes crash Apache server 2.2.9
DescriptionHi,

my settings in the php.ini file are:
[Xdebug]
zend_extension_ts="./ext/php_xdebug.dll"
xdebug.remote_enable=0 (or xdebug.remote_enable=1 to be sure this text between parenthesis I don't have in the php.ini file)
xdebug.default_enable=0
xdebug.remote_host=localhost
xdebug.remote_port=9000
xdebug.remote_handler=dbgp

I using Xdebug with Eclipse PDT 1.0.3, but Eclipse don't have influence to this bug becuase xdebug crash even Eclipse isn't running.

I have programmed application which refresh every several second and around 3-20 refresh xdebug causes crash Apache server.

I'm sure that in PHP 5.2.5 it didn't crash, but I had installed Windows 32bit version and another computer now.

How can I help resolve this bug ? Can I put up any debug information from Xdebug ?
If you give me some info how I can switch Xdebug to the debug mod I send you some log files which I obtain or acquire.

I hope that we resolve this problem together.
Additional InformationIn the Computer managment - Event viewer is always the same error:
Faulting application httpd.exe, version 2.2.9.0, faulting module php_xdebug.dll, version 2.0.3.0, fault address 0x00008493.
TagsNo tags attached.
Operating SystemWindows XP 64bit - Apache server 2.2.9 32bit - PHP 5.2.6 32bit
PHP Version5.2.6

Relationships

duplicate of 0000410 closed Apache crashes on Vista with xDebug installed 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2008-07-15 11:20 snop New Issue
2009-11-27 17:03 derick Relationship added duplicate of 0000410
2009-11-27 17:03 derick Duplicate ID 0 => 410
2009-11-27 17:03 derick Status new => resolved
2009-11-27 17:03 derick Resolution open => duplicate
2009-11-27 17:03 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2020-03-12 16:35 derick Category Usage problems (Wrong Results) => Variable Display
2020-03-12 16:38 derick Category Variable Display => Uncategorized