View Issue Details

IDProjectCategoryView StatusLast Update
0000408Xdebug(No Category)public2008-12-20 19:50
ReportertomasAssigned Toderick 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000408: Script is not aborted on E_RECOVERABLE_ERROR errors
DescriptionA simple code to reproduce the bug:

<?php

$not_an_array = 'string';
a_function($not_an_array);

function a_function(array $array)
{
    // do something
}

echo 'The script has not been aborted?';
?>

The code generates E_RECOVERABLE_ERROR error (the mismatch of argument type). When xdebug is enabled the code is not aborted.
Additional InformationAcording to PHP documentation E_RECOVERABLE_ERROR errors should abort the scripts (http://lt.php.net/manual/en/errorfunc.constants.php)
TagsNo tags attached.
Operating System
PHP Version5.2.3

Relationships

duplicate of 0000391 closed When PHP runs with Xdebug it doesn't stop executing script when type hinting leads to fatal error 

Activities

k-fish

2008-12-11 21:11

reporter   ~0000900

duplicate of 0000391

Issue History

Date Modified Username Field Change
2008-09-09 20:16 tomas New Issue
2008-12-11 21:11 k-fish Note Added: 0000900
2008-12-20 19:49 derick Relationship added duplicate of 0000391
2008-12-20 19:49 derick Duplicate ID 0 => 391
2008-12-20 19:49 derick Status new => resolved
2008-12-20 19:49 derick Resolution open => duplicate
2008-12-20 19:49 derick Assigned To => derick
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)