View Issue Details

IDProjectCategoryView StatusLast Update
0000414XdebugUsage problems (Wrong Results)public2016-12-06 19:18
ReporterlehackAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionwon't fix 
PlatformWindows DevelOSWindowsOS VersionXP SP3
Product Version 
Target Version2.2devFixed in Version 
Summary0000414: XDebug crashing Apache while PHP script tries to access COM
DescriptionI'm having a script here, which tries to access something using COM. This script is executed by an apache 2.2.9 with php 5.2.6 (configured as a module). Having XDebug enabled (but not using it!) executing the script will crash the apache. Deactiviating XDebug in the php.ini will lead to successfull execution of the script. Please note that this happens regardless of the COM-component called (in the example below Word is called). The VS-debugger shows the following message:
Unhandled exception at 0x010e86b4 in httpd.exe: 0xC0000005: Access violation reading location 0x00000025.
and the stacktrace:
> php_xdebug.dll!010e86b4()
     [Frames below may be incorrect and/or missing, no symbols loaded for php_xdebug.dll]
     php_xdebug.dll!010e8b87()
     php_xdebug.dll!010d78bf()
     php5ts.dll!0078c3c7()
     php_xdebug.dll!010d54ef()
     php5ts.dll!0078ce07()
     php5ts.dll!00819572()
     php5ts.dll!007930b5()
     php5ts.dll!0078c595()
     php_xdebug.dll!010d4645()
     php5ts.dll!00772e87()
     php5ts.dll!0082e14d()
     msvcrt.dll!77bfc3c9()
     libhttpd.dll!6ff0a87c()
     libhttpd.dll!6ff04d21()
     libhttpd.dll!6ff04fd3()
     libhttpd.dll!6ff1d2dc()
     msvcrt.dll!77c0a3b0()
     kernel32.dll!7c80b713()
Thanks
Joachim
Steps To Reproduce1. Install apache 2.2.9
2. Install php 5.2.6 and configure it as a module.
3. Install xdebug (i put it in the "ext" directory)
4. execute the script (source is in "additional information".
Additional InformationThe script used to reproduce the error:
<?
try
{
    $oClient = new COM("Word.Application");
    var_dump($oClient);
}
catch(exception $oError)
{
    echo "Error occurred: ";
    var_dump($oError);
}
?>
TagsNo tags attached.
Operating SystemWindows XP SP3
PHP Version5.2.6

Activities

derick

2014-01-03 15:44

administrator   ~0002654

I am not very well versed in Windows development. Setting this bug as Acknowledged, but don't expect any fix any time soon.

lmeyer

2014-12-17 18:55

reporter   ~0002941

I can reproduce this bug on PHP 5.4.16, Apache 2.4 and Windows 2008 R2.
Specifically the overridden function var_dump leads to a crash of Apache. The bug CAN ne mitigated by adding xdebug.overload_var_dump=off to php.ini.

derick

2016-12-04 15:52

administrator   ~0003911

Is this still causing a problem for you? (I know, the issue is 8 years old) ;-)

lmeyer

2016-12-06 07:43

reporter   ~0003949

Last edited: 2016-12-06 07:43

View 2 revisions

I can confirm, that the bug is still persisting. We are still on PHP 5.4.16, Apache 2.4 and Windows 2008 R2, with xdebug.overload_var_dump=off in php.ini.

derick

2016-12-06 19:18

administrator   ~0003951

Support for PHP 5.4 got dropped by the PHP project in August 2015. I don't have anything set-up for this anymore, so I can't ever try to reproduce and fix this.

I am closing this now, but feel free to reopen this if this still a problem with supported versions of PHP (>=7.0) and Xdebug (>=2.5.0).

Issue History

Date Modified Username Field Change
2008-10-11 10:02 lehack New Issue
2010-03-20 23:47 derick Target Version => 2.2dev
2014-01-03 15:44 derick Note Added: 0002654
2014-01-03 15:44 derick Assigned To => derick
2014-01-03 15:44 derick Status new => acknowledged
2014-12-17 18:55 lmeyer Note Added: 0002941
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-12-04 15:52 derick Note Added: 0003911
2016-12-04 15:52 derick Status acknowledged => feedback
2016-12-06 07:43 lmeyer Note Added: 0003949
2016-12-06 07:43 lmeyer Note Edited: 0003949 View Revisions
2016-12-06 19:18 derick Note Added: 0003951
2016-12-06 19:18 derick Status feedback => resolved
2016-12-06 19:18 derick Resolution open => won't fix