View Issue Details

IDProjectCategoryView StatusLast Update
0000430Xdebug(No Category)public2009-11-27 16:58
ReportergbrauxAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
PlatformWIN32OSWindows Server 2008OS Version
Product Version 
Target VersionFixed in Version 
Summary0000430: php.exe crash (Access violation) when debug_enable( ) called
DescriptionPhp crash when running with :
xdebug.default_enable = 1 in php.ini (default)
or
when xdebug_enable() is set in the php code.

The remote debug mode works very well, only the "local" debug (show stack trace on pages ...) no not work.

The Access Violation (in php.exe or php-cgi.exe when called from IIS) is made in NTDLL.exe. No trace of xdebug.dll in the crash stack (only php.exe and ntdll)

The problem really seemed to be a threading problem, as the xdebug dll do not appears in stack ...
Steps To ReproduceInstall xdebug 2.0.5 for php5.2.x NTS with the same configuration as mine ...
Additional InformationRunning configuration :
Windows Server 2008 Web Edition
IIS 7
FastCGI
PHP 5.2.4 NON THREADSAFE (ZTS=0) / ZendCore 2.5.0 (all default zend extensions disabled)
Xdebug.dll 2.0.4 NTS self compiled with VC9 + libphp5 (same crash with downloadable nts binary).

zend_extension=path/xdebug.dll (in php.ini)
TagsNo tags attached.
Operating System
PHP Version5.2.4

Relationships

duplicate of 0000410 closed Apache crashes on Vista with xDebug installed 

Activities

gbraux

2009-02-21 11:32

reporter   ~0000919

FYI :

Faulting application php-cgi.exe, version 5.2.4.4, time stamp 0x47013732, faulting module ntdll.dll, version 6.0.6001.18000, time stamp 0x4791a7a6, exception code 0xc0000005, fault offset 0x000682f8, process id 0x1258, application start time 0x01c9940f2116f906.

 php-cgi.exe
   5.2.4.4
   47013732
   ntdll.dll
   6.0.6001.18000
   4791a7a6
   c0000005
   000682f8
   1258
   01c9940f2116f906

Issue History

Date Modified Username Field Change
2009-02-21 00:02 gbraux New Issue
2009-02-21 00:02 gbraux PHP Version => 5.2.4
2009-02-21 00:02 gbraux Xdebug Version => 2.0.4-dev
2009-02-21 11:32 gbraux Note Added: 0000919
2009-11-27 16:58 derick Relationship added duplicate of 0000410
2009-11-27 16:58 derick Duplicate ID 0 => 410
2009-11-27 16:58 derick Status new => resolved
2009-11-27 16:58 derick Resolution open => duplicate
2009-11-27 16:58 derick Assigned To => derick
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)