View Issue Details

IDProjectCategoryView StatusLast Update
0000446XdebugUsage problems (Wrong Results)public2009-12-29 14:32
ReporterkirbysayshiAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000446: xdebug.profiler_enable_trigger requires xdebug.profiler_enable set to 0
DescriptionI'm fairly new to xdebug, but have been using it for a few weeks. Today, I tried getting profiling working on OS X 10.5.7 using XAMPP. I spent a few hours trying to figure out the following problem:

Even though I had set xdebug.profiler_enable_trigger to 1, each time I loaded a page a log file was written. Eventually, I found a single blog post that mentioned that you have to have xdebug.profiler_enable set to 0 to use the trigger. While this definitely makes sense in retrospect, I feel like it's not obvious... my thinking was that, of course you have to have the whole thing enabled for ANYTHING to work.
Additional InformationI originally posted this to the mailing list as an edit for the documentation. I was told this might actually be a bug, so here it is.

Also, my PHP version is actually 5.2.9, but that isn't listed here.
TagsNo tags attached.
Operating SystemOS X 10.5.7
PHP Version5.2.8

Activities

derick

2009-12-29 14:32

administrator   ~0001225

I've had a look at this, and the current behaviour is as it should be. The reason is that if profiler_enable is set to 1, we can't rely on what profiler_enable_trigger should be, as it would break previous behaviour. I've documented this now though.

Issue History

Date Modified Username Field Change
2009-06-17 17:50 kirbysayshi New Issue
2009-06-17 17:50 kirbysayshi Operating System => OS X 10.5.7
2009-06-17 17:50 kirbysayshi PHP Version => 5.2.8
2009-06-17 17:50 kirbysayshi Xdebug Version => 2.0.3
2009-12-29 14:32 derick Note Added: 0001225
2009-12-29 14:32 derick Status new => resolved
2009-12-29 14:32 derick Resolution open => no change required
2009-12-29 14:32 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)