View Issue Details

IDProjectCategoryView StatusLast Update
0000447XdebugUsage problems (Wrong Results)public2009-07-09 17:54
Reportercagret2Assigned Toderick 
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionunable to reproduce 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000447: Negative time column in .xt generated file
DescriptionI got a strange result in .xt file, it was only 1 row (there are about 12k of calls to explode), and it had a negative time column:

3 10050 0 0.828078 3606880 explode 0 referer-report.php 258
3 10050 1 0.828104 3606880
3 10051 0 -0.171878 3606880 explode 0 referer-report.php 258
3 10051 1 0.828289 3606880
3 10052 0 0.828316 3606880 explode 0 referer-report.php 258

It happened only once, could not reproduce it again.

Source code:

256: <? foreach ($refs as $id => $hits): ?>
255: <?
258: $arr = explode('%%%%%', $id);
259: $uri = $arr[0];
260: $from = $arr[1];
Additional InformationDll: php_xdebug-2.0.4-5.2.8-nts.dll
Php: 5.2.6-nts as fcgi
OS: Win XP SP3
Server: Lighttpd
TagsNo tags attached.
Operating SystemWin XP SP3
PHP Version5.2.6

Activities

derick

2009-07-09 17:54

administrator   ~0000987

I can't reproduce this either. perhaps your computer's clock was automatically adjusted some how during this run. Closing.

Issue History

Date Modified Username Field Change
2009-06-20 21:20 cagret2 New Issue
2009-06-20 21:20 cagret2 Operating System => Win XP SP3
2009-06-20 21:20 cagret2 PHP Version => 5.2.6
2009-06-20 21:20 cagret2 Xdebug Version => 2.0.4-dev
2009-07-09 17:54 derick Note Added: 0000987
2009-07-09 17:54 derick Status new => resolved
2009-07-09 17:54 derick Resolution open => unable to reproduce
2009-07-09 17:54 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)