View Issue Details

IDProjectCategoryView StatusLast Update
0000046XdebugUsage problems (Wrong Results)public2004-05-31 13:05
ReporterduncanAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0000046: Segmentation fault with PHP5.0.0b4 in threadsafe
DescriptionPHP 5.0.0b4 exits with a segmentation fault if xdebug is installed as a thread-safe module with zend_extension_ts. This occurs with xdebug 1.3 and the latest version from CVS. The problem is with b4, it worked fine under b3.
TagsNo tags attached.
Operating SystemRedhat Linux 9
PHP Version5.0.0-dev

Activities

duncan

2004-02-24 07:46

reporter   ~0000098

Additional. Probably has something to do with the API change Zend made in b4

derick

2004-02-25 17:09

administrator   ~0000099

Does this happen with every script? If not, please provide a short! testing script. If you can, please also provide a backtrace.

duncan

2004-02-26 02:31

reporter   ~0000100

Seems to occur with every invocation of php, even just simply fetching the version with -v. Running with a <? phpinfo() ?> as input, the script outputs all system variables and the PHP license before seg faulting.

I tried running it with gdb to get a backtrace but it wasn't being helpful, do I need to compile with any special options?

compiler flags being used by default are: -O2 -pipe -march=i686 -fomit-frame-pointer

As stated, everything worked fine until the change from b3 to b4

derick

2004-02-27 21:07

administrator   ~0000104

can you please compile without any of those flags, and add --enable-debug to your PHP configure line? That should give you a much better backtrace. I still can't reproduce your segfault here.

derick

2004-05-31 13:05

administrator   ~0000140

No feedback.

Issue History

Date Modified Username Field Change
2004-02-24 03:11 duncan New Issue
2004-02-24 07:46 duncan Note Added: 0000098
2004-02-25 17:09 derick Note Added: 0000099
2004-02-25 17:09 derick Status new => feedback
2004-02-26 02:31 duncan Note Added: 0000100
2004-02-27 21:07 derick Note Added: 0000104
2004-05-31 13:05 derick Status feedback => resolved
2004-05-31 13:05 derick Resolution open => suspended
2004-05-31 13:05 derick Assigned To => derick
2004-05-31 13:05 derick Note Added: 0000140
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)