View Issue Details

IDProjectCategoryView StatusLast Update
0000473Xdebug(No Category)public2009-12-27 14:30
ReporterdionyzizAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000473: Remote debugging `show-locals' and `show' fails with crash when examining arrays
DescriptionIn XDebug 2.0.5 (stable), when remote debugging on a Debian server and a Debian client using "gdb" debugging mode, the following always causes a crash.

Type the following code and save it as test.php:
<?php
    function Test() {
        $q = array( 1, 2, 5 );
        xdebug_break();
    }
    Test();
?>

Visit test.php with remote debugging enabled. Have a debugging client wait to accept remote connections, for example using netcat:

> nc -lvvv -p 9000

Upon connection, issue "run" to start the script. The script will enter the Test function and break. Issue "next" to get out of the "xdebug_break" callstack and get ready to execute the "}" line of the function.

Issue a "show" or "show-locals". The program will immediately crash and disconnect from the debug client.
TagsNo tags attached.
Operating SystemDebian 2.6.26-2-openvz-amd64
PHP Version5.2.10

Activities

derick

2009-10-17 17:06

administrator   ~0001097

I can not reproduce this with Xdebug's HEAD from CVS, could you please try?

derick

2009-12-27 14:30

administrator   ~0001210

Requested feedback not provided.

Issue History

Date Modified Username Field Change
2009-09-24 01:21 dionyziz New Issue
2009-09-24 01:21 dionyziz Operating System => Debian 2.6.26-2-openvz-amd64
2009-09-24 01:21 dionyziz PHP Version => 5.2.10
2009-09-24 01:21 dionyziz Xdebug Version => 2.0.5
2009-10-17 17:06 derick Note Added: 0001097
2009-10-17 17:06 derick Status new => feedback
2009-12-27 14:30 derick Note Added: 0001210
2009-12-27 14:30 derick Status feedback => resolved
2009-12-27 14:30 derick Resolution open => unable to reproduce
2009-12-27 14:30 derick Assigned To => derick
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)