View Issue Details

IDProjectCategoryView StatusLast Update
0000477XdebugUsage problems (Wrong Results)public2009-10-24 18:15
ReporterechangAssigned Toderick 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000477: XDebug 2.0.5 doesn't work with function variables
DescriptionWhen I step into functions, I cannot trace the value of function variables, and it is always <Uninitialized> for any function variable.

My PHP and XDebug:
PHP 5.3.0 (cli) (built: Jul 2 2009 21:08:11)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2009 Zend Technologies
    with Xdebug v2.0.5, Copyright (c) 2002-2008, by Derick Rethans

TagsNo tags attached.
Operating SystemWindows XP SP3 with Eclipse Galileo + PDT
PHP Version5.3.0

Activities

derick

2009-10-24 18:15

administrator   ~0001113

This is fixed in CVS already.

Issue History

Date Modified Username Field Change
2009-10-24 03:01 echang New Issue
2009-10-24 03:01 echang Operating System => Windows XP SP3 with Eclipse Galileo + PDT
2009-10-24 03:01 echang PHP Version => 5.3.0
2009-10-24 03:01 echang Xdebug Version => 2.0.5
2009-10-24 18:15 derick Note Added: 0001113
2009-10-24 18:15 derick Status new => resolved
2009-10-24 18:15 derick Resolution open => duplicate
2009-10-24 18:15 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)