View Issue Details

IDProjectCategoryView StatusLast Update
0000485XdebugUsage problems (Wrong Results)public2009-12-29 13:05
ReporterdeltremAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000485: path problem with mod_rewrite, XDebug, PDT and XAMPP
Description- debugging index.php as PHP Script is working
- debugging account/create as PHP Script is working

- debugging index.php as PHP Web Page is working
(my mod_rewrite makes account/create be index.php?folder=account&action=create)
- debugging account/create as PHP Web Page without mod_rewrite is working
- debugging account/create as PHP Web Page with mod_rewrite isn't working
Additional Informationphp.ini:
    zend_extension = "\xampp\php\ext\php_xdebug.dll"
    xdebug.idekey=ECLIPSE_XDEBUG
    xdebug.profiler_enable=1
    xdebug.remote_enable=1
    xdebug.remote_handler="dbgp"
    xdebug.remote_host="localhost"
    xdebug.remote_mode="req"
    xdebug.remote_port=9000

Start ->
    Control Panel ->
        Firewall ->
            Exceptions ->
                Add Port ->
                    Name:
                    XDebug

                    Port number:
                    9000

Window ->
    Preferences ->
        PHP ->
            Debug ->
                PHP Debugger:
                XDebug

                Server:
                localhost

                PHP Executables:
                C:\xampp\php\php-cgi.exe

Debug Configurations ->
    MyFrame Web Page ->
        Server ->
            PHP Server ->
                Configure ->
                    Server ->
                        Name:
                        localhost

                        Enter the URL that points to the document root of this server:
                        http://localhost/frameworks

                        Path Mapping ->
                            (serverpath) http://localhost/frameworks/myframe/index.php
                            to
                            (filesystem) C:\xampp\htdocs\frameworks\myframe\index.php

                            (serverpath) http://localhost/frameworks/myframe/index.php
                            to
                            (workspace) /myframe/index.php

            File:
            /myframe/index.php

            URL:
            http://localhost/ by the left
            frameworks/myframe/index.php by the right

        Advanced ->
            (checked) Open in Browser
            (checked) Debug All Pages
TagsNo tags attached.
Operating SystemWindows XP
PHP Version5.3.0

Activities

deltrem

2009-11-06 23:47

reporter   ~0001123

the .htaccess contents

<IfModule mod_rewrite.c>
   RewriteEngine on
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteRule ^([^/]*)/?([^/]*)/?([^/]*)$ index.php?folder=$1&action=$2&params=$3 [L]
</IfModule>

derick

2009-11-08 21:47

administrator   ~0001124

This is not enough information, please provide a remote debugging log (see "Remote Debugger Bugs" at http://xdebug.org/support.php

deltrem

2009-11-08 23:37

reporter   ~0001125

I set remote_log to "C:\xampp\htdocs\xdebug_log.txt"
http://i.imagehost.org/view/0176/php_ini_xdebug_log

I made all users have write permissions to it.
(All the other users have write permissions to it by default.)
Seguran├ža = Security
Gravar = Write
http://i.imagehost.org/view/0922/xdebug_log

I restarted Apache and MySQL in the Xampp Control Panel.

I terminated and relaunched MyFrame as PHP Web Page in PDT.

"xdebug_log.txt" is empty!


Do you need to know anything else to solve this problem?

deltrem

2009-11-19 16:50

reporter   ~0001143

Why hasn't my question been answered?

deltrem

2009-12-18 13:58

reporter   ~0001200

Last edited: 2009-12-18 14:03

BIG NEWS!!!

I'm not using eclipse any longer, I'm using Komodo now and in the ActiveState (they make Komodo) site:

- I read a post (at http://community.activestate.com/forum-topic/problem-php-remote-debugging) saying that XDebug shouldn't load at the same time as a regular module and a Zend Extension, but I'm loading it at the same time as a regular module and a Zend Extension.

- I read a documentation page (http://docs.activestate.com/komodo/5.2/debugphp.html#config_remote_PHP) saying that in Windows I should be using zend_extension_ts and not zend_extension, but I'm using zend_extension and not zend_extension_ts.


While trying to solve these problems:

- when I search for xdebug in php.ini, it's in the "zend_extension" without "_ts" list and isn't in the "extension =" without "zend_" list. So, then, why is it being loaded as a regular module and a zend extension?

- when I was using zend_extension, XDebug was appearing in phpinfo(). When I started using zend_extension_ts, XDebug stopped appearing in phpinfo(). So, then, why should I use zend_extension_ts instead of zend_extension?

derick

2009-12-29 13:05

administrator   ~0001222

- It is because Xdebug is *both* a zend extension and a normal one, but it needs to be loaded as Zend Engine extension to include both required parts. Loading Xdebug as a normal extension will make much functionality break. Xdebug will show up (with php -m) as both types of extensions, but it can only be loaded as a zend extension (with zend_extension=). I think the Komodo docs point at zend extension as made by Zend (the company).

- Komodo's documentation is not 100% correct. Since PHP 5.3 the _ts and _debug suffixes to zend_extension are no longer required.

Issue History

Date Modified Username Field Change
2009-11-06 23:13 deltrem New Issue
2009-11-06 23:13 deltrem Operating System => Windows XP
2009-11-06 23:13 deltrem PHP Version => 5.3.0
2009-11-06 23:13 deltrem Xdebug Version => 2.0.5
2009-11-06 23:47 deltrem Note Added: 0001123
2009-11-08 21:47 derick Note Added: 0001124
2009-11-08 21:47 derick Status new => feedback
2009-11-08 23:37 deltrem Note Added: 0001125
2009-11-19 16:50 deltrem Note Added: 0001143
2009-12-18 13:58 deltrem Note Added: 0001200
2009-12-18 13:59 deltrem Note Edited: 0001200
2009-12-18 14:03 deltrem Note Edited: 0001200
2009-12-29 13:05 derick Note Added: 0001222
2009-12-29 13:05 derick Status feedback => resolved
2009-12-29 13:05 derick Resolution open => no change required
2009-12-29 13:05 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)