View Issue Details

IDProjectCategoryView StatusLast Update
0000527XdebugInstallationpublic2010-02-01 17:53
ReporterWebDevHoboAssigned Toderick 
Status resolvedResolutionno change required 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000527: Cannot make on Ubuntu 9.10
DescriptionI am working on Ubuntu 9.10, with XAMPP 1.7.3a installed.

Documentation for which can be found here:

I stopped the apache service before trying to make xdebug.
Step 1-4 work as expected, step 5, simply executing make, returns numerous errors, more than 500 lines, which is the scrollback of my terminal.

The modules map is created, but it empty.

The commend used for Step 4 was this:
./configure --enable-xdebug --with-php-config=/opt/lampp/bin/php-config-5.3.1

This gave no errors
Additional InformationThis Ubuntu 9.10 is a virtual machine, running on VmWare Workstation 7.0, which is running on on Windows 7 Ultimate 32-bit
TagsNo tags attached.
Operating SystemUbuntu 9.10
PHP Version5.3.1



2010-01-30 17:04

reporter   ~0001297

Tried the same thing with the 2.0.5 source TGZ, with the exact same result.
Here you can read the output of the make command:


2010-01-30 17:06

administrator   ~0001298

Please provide a whole transcript of you're trying to compile it.


2010-01-30 17:14

reporter   ~0001299

You mean every step I took, including the installation of XAMPP?


2010-01-30 17:30

administrator   ~0001300

I don't really care about XAMPP... if you think it's useful, include it anyway.


2010-01-30 17:52

reporter   ~0001301

Last edited: 2010-01-30 17:53

Step 1: Downloaded the 2.0.5 TGZ file from the website, which was saved to /home/WebDevHobo/Downloads/

Step 2: Opened a terminal, execute command "sudo su -" to execute further actions as root.

Step 3: Navigate to the Downloads folders, execute the command: "tar -xzf xdebug-2.0.5.tgz -C /opt"

Step 4: Navigate to the /opt/xdebug-2.0.5/ folder.

Step 5: Execute the command "/opt/lampp/bin/phpize-5.3.1". Output can be viewed here:

Step 6: Execute the command "./configure --enable-xdebug --with-php-config=/opt/lampp/bin/php-config-5.3.1". Output can be viewed here:

Step 7: Execute the command "make". Output van be viewed here:

And that's where I'm stuck. The created modules folder, needed in the next step, is empty.

I'm signing off for today.


2010-01-31 20:39

reporter   ~0001310

I think that you're missing the php5-dev package. php.h and php_version.h look like they're missing on your system and are provided by php5-dev.


2010-02-01 01:59

reporter   ~0001311

Last edited: 2010-02-01 02:45

Thanks, problem resolved.

For future reference, the steps taken to solve this were:

1) Become root at the command line by use of the command "sudo su -"

2) Remove the old folder: "rm -r /opt/xdebug-2.0.5/"

3) Do a fresh tar of the file: "tar -xfz /path/to/xdebug.tar -C /opt".

4) Install php5-dev: "apt-get install php5-dev"

5) Navigate to the /opt/xdebug-2.0.5 folder

6) Execute the command: "/usr/bin/phpize5"

7) Execute the command: "./configure --enable-xdebug" (MUST be done from within the /opt/xdebug-2.0.5 folder)

8) Execute the command: "make"

And it worked. I then copied to /opt/lampp/lib

All that is left is to add this code:

To all php.ini files.

However, a new problem has risen.
When executing php -m, xdebug does show up in the Zend_Modules, but the phpinfo() result does not show it as active.

When trying to debug in Netbeans, with everything restarted and all php.ini files saved, there's no response, Netbeans just keeps waiting for the connection that never comes.

File a separate bug?


2010-02-01 16:29

reporter   ~0001313

I uninstalled XAMPP and followed the instructions in this video:

Up to the point of Xdebug.
And hooray, everything works, I can debug succesfully with Netbeans.

I'm thinking the problem here was XAMPP, and no XDEBUG.

Issue History

Date Modified Username Field Change
2010-01-30 16:51 WebDevHobo New Issue
2010-01-30 16:51 WebDevHobo Operating System => Ubuntu 9.10
2010-01-30 16:51 WebDevHobo PHP Version => 5.3.1
2010-01-30 16:51 WebDevHobo Xdebug Version => 2.1.0beta1
2010-01-30 17:04 WebDevHobo Note Added: 0001297
2010-01-30 17:06 derick Note Added: 0001298
2010-01-30 17:06 derick Status new => feedback
2010-01-30 17:14 WebDevHobo Note Added: 0001299
2010-01-30 17:30 derick Note Added: 0001300
2010-01-30 17:52 WebDevHobo Note Added: 0001301
2010-01-30 17:52 WebDevHobo Note Edited: 0001301
2010-01-30 17:53 WebDevHobo Note Edited: 0001301
2010-01-31 20:39 tanooki Note Added: 0001310
2010-02-01 01:59 WebDevHobo Note Added: 0001311
2010-02-01 02:24 WebDevHobo Note Edited: 0001311
2010-02-01 02:25 WebDevHobo Note Edited: 0001311
2010-02-01 02:30 WebDevHobo Note Edited: 0001311
2010-02-01 02:41 WebDevHobo Note Edited: 0001311
2010-02-01 02:45 WebDevHobo Note Edited: 0001311
2010-02-01 16:29 WebDevHobo Note Added: 0001313
2010-02-01 17:53 derick Status feedback => resolved
2010-02-01 17:53 derick Resolution open => no change required
2010-02-01 17:53 derick Assigned To => derick