View Issue Details

IDProjectCategoryView StatusLast Update
0000553XdebugUsage problems (Wrong Results)public2010-07-08 10:22
ReporterbfelipeeAssigned Toderick 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version2.1.0RC1 
Target VersionFixed in Version 
Summary0000553: segmentation fault
Descriptionsegmentation fault error is thrown when I am trying to debug with dev version of xdebug (rev 3241), apache 2.2

not reproducible with latest beta.
Additional Informationapache error log after trying to run with new xdebug (rev 3241)
[Fri Mar 26 15:18:44 2010] [notice] caught SIGTERM, shutting down
PHP Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
PHP Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
[Fri Mar 26 15:18:45 2010] [notice] Apache/2.2.12 (Ubuntu) PHP/5.3.2 mod_ssl/2.2.12 OpenSSL/0.9.8g configured -- resuming normal operations
[Fri Mar 26 15:19:08 2010] [notice] child pid 25645 exit signal Segmentation fault (11)
TagsNo tags attached.
Operating System
PHP Version5.3.2

Activities

derick

2010-03-31 08:11

administrator   ~0001411

If it works with the latest beta, then of course it's fixed...

bfelipee

2010-03-31 08:15

reporter   ~0001413

bug is reported against rc1, beta is lower version. To be more clear, workED in beta, reproducible in rc1 development (svn checkout)

derick

2010-03-31 17:58

administrator   ~0001421

Alright, then I need a reproducible script and a backtrace. The back trace should be made with zend memory manager off (export USE_ZEND_ALLOC=1): http://bugs.php.net/bugs-generating-backtrace.php

A valgrind report would be extremely helpful as well.

bfelipee

2010-03-31 18:11

reporter   ~0001422

sure, no problem. going on vacation in couple of minutes so I will make this next week for you. thanks.

derick

2010-04-13 19:46

administrator   ~0001449

Would you have the requested information already?

derick

2010-07-08 10:22

administrator   ~0001523

No feedback, and can't reproduce.

Issue History

Date Modified Username Field Change
2010-03-26 14:23 bfelipee New Issue
2010-03-26 14:23 bfelipee PHP Version => 5.3.2
2010-03-26 14:23 bfelipee Xdebug Version => 2.1.0-dev
2010-03-31 08:11 derick Note Added: 0001411
2010-03-31 08:11 derick Status new => resolved
2010-03-31 08:11 derick Resolution open => fixed
2010-03-31 08:11 derick Assigned To => derick
2010-03-31 08:15 bfelipee Note Added: 0001413
2010-03-31 08:15 bfelipee Status resolved => feedback
2010-03-31 08:15 bfelipee Resolution fixed => reopened
2010-03-31 17:58 derick Note Added: 0001421
2010-03-31 18:11 bfelipee Note Added: 0001422
2010-04-13 19:46 derick Note Added: 0001449
2010-07-08 10:22 derick Note Added: 0001523
2010-07-08 10:22 derick Status feedback => resolved
2010-07-08 10:22 derick Resolution reopened => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)