View Issue Details

IDProjectCategoryView StatusLast Update
0000559XdebugUsage problems (Wrong Results)public2010-04-05 17:08
ReporterandreaswolfAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000559: Profile trigger does not work with POST and COOKIE
DescriptionI tried to get XDebug Profiler to work on a trigger. It works perfectly when using GET requests, but as soon as I try to do it via POST or COOKIE, there is no output.

The configuration is as follows:


[xdebug]
xdebug.profiler_enable_trigger = 1

xdebug.profiler_append = 1

xdebug.profiler_output_dir = /tmp/xdebug/
Additional InformationMy environment is:

* MacOS X 10.5.8
* Apache 2.2.14, PHP 5.3.2, XDebug 2.0.5 (all from MacPorts)
* Firefox 3.6.2

I used Firefox extensions TamperData (for injecting the POST var) and Easy XDebug (for the Cookie thingie). As far as I can tell, both did their job and injected the data, at least it arrived at the server.
TagsNo tags attached.
Operating SystemMac OS X 10.5.8
PHP Version5.3.2

Activities

derick

2010-04-05 16:17

administrator   ~0001434

This works just fine for me. Can you try the latest version with SVN, and if it doesn't work provide the engine and xdebug sections (only) of phpinfo() output?

andreaswolf

2010-04-05 16:21

reporter   ~0001435

I'll try it later today.

Maybe the problem with POST requests is that it was originally a GET request and TamperData just added the POST parameter (or maybe not, I'm not sure if it's allowed by the HTTP RFCs to add POST data to a GET request - and what Apache and PHP do in such a case). Unfortunately my C knowledge is by far not deep enough to understand the source of XDebug at that point. Neither is my knowledge of debugging such problems, so I could not track it down myself.

andreaswolf

2010-04-05 17:06

reporter   ~0001436

Ah. I'm sorry - I've found the error. I use the Firefox extension CookiePie for developing on my TYPO3 websites, so I can have multiple tabs with the same site, but with different logins. The problem is that CookiePie does not send the XDEBUG_PROFILE cookie, though Easy XDebug showed profiling as enabled in the bottom right corner...

The other problem I mentioned (HTTP POST data not read with GET requests) still persists, but I bet that it gets lost somewhere in Apache or PHP, so there might be nothing XDebug can do about that.

All in all, I think this bug can be closed - I'm sorry for the inconvenience caused. Just another thing: XDebug's tests in trunk threw some errors, which I have posted to qa.php.net - if you want to do something about that and need a tester, don't hesitate to contact me. And keep up the good work with XDebug! :)

andreaswolf

2010-04-05 17:07

reporter   ~0001437

One final note: Maybe it would be worth adding a note to the docs that people should be careful with any browser extensions that fiddle around with cookies and request data. Maybe a short PHP test script that displays all data it got and whether XDebug was enabled for that request or not would be a great help in such situations.

derick

2010-04-05 17:08

administrator   ~0001438

Alright, closing then. I know there are some test failures, and will be looking at them.

Issue History

Date Modified Username Field Change
2010-04-05 08:58 andreaswolf New Issue
2010-04-05 08:58 andreaswolf Operating System => Mac OS X 10.5.8
2010-04-05 08:58 andreaswolf PHP Version => 5.3.2
2010-04-05 08:58 andreaswolf Xdebug Version => 2.0.5
2010-04-05 16:17 derick Note Added: 0001434
2010-04-05 16:17 derick Status new => feedback
2010-04-05 16:21 andreaswolf Note Added: 0001435
2010-04-05 17:06 andreaswolf Note Added: 0001436
2010-04-05 17:07 andreaswolf Note Added: 0001437
2010-04-05 17:08 derick Note Added: 0001438
2010-04-05 17:08 derick Status feedback => resolved
2010-04-05 17:08 derick Resolution open => fixed
2010-04-05 17:08 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)